0
$\begingroup$

Rosanswers logo

Hi guys,

I'm trying to import my robotmodel on rviz but when I change the urdf file from

to a mesh (created by sketchup) like

when i run rviz the shell tell me

[ERROR] [1370333859.322282991]: Could not load resource [package://robo01.dae]: Unable to open file "package://robo01.dae". [ERROR] [1370333859.324037613]: Could not load model 'package://robo01.dae' for link 'base_link': OGRE EXCEPTION(6:FileNotFoundException): Cannot locate resource package://robo01.dae in resource group Autodetect or any other group. in ResourceGroupManager::openResource at /build/buildd/ogre-1.7.4/OgreMain/src/OgreResourceGroupManager.cpp (line 753)

following this post https://code.ros.org/gf/project/ros/mailman/?_forum_action=ForumMessageBrowse&thread_id=56835&action=ListThreads&mailman_id=20

i try

ls rospack find urdf_tutorial/robo01.dae

and it tell me that the file is in correct place (??).

Could someone tell me what I'm doing wrong?

thanks a lot guys for your answer


Originally posted by danielq on ROS Answers with karma: 181 on 2013-06-03

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hi @danielq,

You need to specify the actual package name and subdirectory (if any) in your URL. So try this:

If your model was in a subdirectory of the urdf_tutorial package called "meshes" (for example), you would use:

--patrick


Originally posted by Pi Robot with karma: 4046 on 2013-06-07

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by danielq on 2013-06-07:
thanks Patrick for the answer. It was soo simple soo it works.

Comment by Pi Robot on 2013-06-12:
Hi @danielq. Glad that did the trick. Please mark the answer as "correct" by clicking the checkmark above.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.