0
$\begingroup$

Rosanswers logo

Can your ros_workspace folder be located on an NTFS file system?

I'm using ros electric and a wubi install of ubuntu 11.10.

I've added a new hard drive that I want both windows and linux to access, and I'd like to move my ros_workspace folder to the new hard drive. Unfortunately when I run my nodes from the new environment I get:

$ rosrun loader_testing boomPosCnt

[rosrun] Couldn't find executable named boomPosCnt below /media/may2013/ros_workspace/loader_testing [rosrun] Found the following, but they're either not files, [rosrun] or not executable: [rosrun] /media/may2013/ros_workspace/loader_testing/bin/boomPosCnt

When I switch the environment back to the old workspace in my home folder (ext4 file system) the nodes run fine. Thanks!


Originally posted by 4praytor on ROS Answers with karma: 5 on 2013-05-30

Post score: 0


Original comments

Comment by 4praytor on 2013-05-30:
Thanks mirzashah your idea worked!

I wound up following this post to remount the drive: http://ubuntuforums.org/showthread.php?t=1604251

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

This is a duplicate of another question: http://answers.ros.org/question/63952/ros-workspace-file-system/


Originally posted by mirzashah with karma: 1209 on 2013-05-30

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.