0
$\begingroup$

Rosanswers logo

Is it possible to use an older version of OpenCV with ROS Groovy (current version is 2.4.4)? If so, how could I change to a different version?


Originally posted by ryeakle on ROS Answers with karma: 36 on 2013-05-12

Post score: 0


Original comments

Comment by Mac on 2013-05-13:
Out of curiosity, why do you want to do this?

Comment by ryeakle on 2013-05-13:
My team was using the cvblobslib to do some object localization. When we used 2.4.4, everything builds, but the blob detection (cvblobslib) doesn't work. Compiled on our old machine with Fuerte and OpenCV 2.4.2, it does work. We ended up re-writing our program to work with a different blob library.

Comment by Mac on 2013-05-13:
Huh. If you haven't, it might be good to file a bug against cvblobslib, just to let them know that OpenCV changed out from under them.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

If you want a different version of OpenCV you should create a workspace with all packages which depend on it and the older version of OpenCV and compile from source.


Originally posted by tfoote with karma: 58457 on 2013-05-13

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.