0
$\begingroup$

Rosanswers logo

Dear Ros community,

After the last update in ros fuerte, move_base and map_server die after launch them with launch apps [1][2] that used to work properly.

They doesn't give much information, for instance:

[move_base-3] process has died [pid 10283, exit code -4, [...]

I tried to find a solution and I haven't found any.

This is the configuration of the system:

  • Ubuntu 12.04 64bit
  • ROS Fuerte
  • ros-fuerte-navigation 1.8.3-s1367591379~precise

Has anybody found a similar problem? or have a clue of a possible problem/solution?

Thanks in advance,

see you saturday!

[1] http://devel.iri.upc.edu/pub/labrobotica/ros/iri-ros-pkg/stacks/iri_teaching/upc_mobrob/launch/fuerte/sim_stage_navigation.launch

[2] http://devel.iri.upc.edu/pub/labrobotica/ros/iri-ros-pkg/stacks/iri_teaching/upc_mobrob/launch/fuerte/sim_move_base.launch


Originally posted by martimorta on ROS Answers with karma: 843 on 2013-05-09

Post score: 1


Original comments

Comment by jarvisschultz on 2013-05-09:
I am having major problems since the last Fuerte update as well. Every node I try and run that uses pcl is crashing. I'm guessing something went wrong during packaging. I filed a bug report with perception_pcl (wrong place) error here

Comment by martimorta on 2013-05-14:
Thanks @jarvisschultz, I followed the instructions of the patch there and it worked.

Comment by tfoote on 2013-05-27:
What does the log file for the move-base node contain?

Comment by martimorta on 2013-05-28:
Hi Tully, It says log file: /home/chaplin/.ros/log/3a0dfd2e-c790-11e2-9b26-c417fe1f097c/move_base-3*.log but there's not actual log file and the logs don't give other information.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

How did you get the latest Fuerte update? Did you do it with "apt-get update" and "apt-get install ..." or "apt-get upgrade"? I have seen problems with version dependencies not being modeled super carefully in the ROS debian packages (they tell me it is difficult, and I don't doubt it).

The result is they recommend to always upgrade by doing

sudo apt-get update
sudo apt-get dist-upgrade

"dist-upgrade" upgrades every package in your system to the latest available. It takes longer, but is more reliable with ROS packages.

If all that does not help, I usually follow the instructions here to run just the node in question in gdb, so I can get a stack trace.


Originally posted by hersh with karma: 1351 on 2013-05-09

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by martimorta on 2013-05-09:
Thank you, I'll try it as soon as I can. And yes, I did upgrade not dist-upgrade.

Comment by martimorta on 2013-05-13:
Hi, this solution hasn't worked, but thanks for the answer, it may be useful another time.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.