0
$\begingroup$

Rosanswers logo

I installed and built rgbdslam_freiburg as given in http://www.ros.org/wiki/rgbdslam. When I tried to execute the following command

roslaunch rgbdslam kinect+rgbdslam.launch

I got the following error:

ERROR: cannot launch node of type [rgbdslam/rgbdslam]: can't locate node [rgbdslam] in package [rgbdslam]

'roscd' is able to locate the package rgbdslam. It is found inside my catkin workspace, where I downloaded the code from this link http://alufr-ros-pkg.googlecode.com/svn/trunk/rgbdslam_freiburg given in the tutorial

However rosnode info rgbdslam returns cannot contact [/rgbdslam]: unknown node

I'm running ros groovy on Ubuntu 12.10


Originally posted by Maheshwar Venkat on ROS Answers with karma: 5 on 2013-05-08

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Have you compiled it? It's not a binary download. See the wiki page for how to do it.


Originally posted by Felix Endres with karma: 6468 on 2013-05-14

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by leo pauly on 2014-01-20:
compiled it. but still it shows same error..

Comment by Felix Endres on 2014-01-23:
And compilation was successful, I assume. You have to find the binary then. Try searching in your workspace with "find -executable -name rgbdslam -type f".

Comment by Michiel on 2014-01-29:
I have the same problem. Compilation was succesful. Any update on this?

Also, I noticed that I can't use rosrun or roscd, altough I included "source /opt/ros/hydro/setup.bash" in my ~/.bashrc file. The other ros-commands are working.

Comment by Felix Endres on 2014-02-14:
I have migrated rgbdslam to hydro. Let me know whether you would like to test a probably unstable release.

Comment by leo pauly on 2014-02-22:
im running on ros hydro.but still the error continues

Comment by Felix Endres on 2014-02-25:
Leo: Please be specific. You are running what on ros hydro? The rgbdslam package from googlecode?

Comment by Felix Endres on 2014-02-25:
Michiel:Have you created a workspace and sourced the respective setup.bash, so that rgbdslam is in your package path? Check with "echo $ROS_PACKAGE_PATH"

Comment by pinocchio on 2014-03-26:
@leo pauly @Michiel @Felix Endres Do you use catkin workspace or rosbuild one? The instruction uses a rosbuild ws. I am not sure which is correct to install this package on hydro.

Comment by Felix Endres on 2014-03-27:
For fuerte I am using rosbuild. For the (yet unreleased) hydro version I use catkin

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.