0
$\begingroup$

Rosanswers logo

Hi, I'm trying to run rgbdslam with the openni_launch packet setted to qvga via dynamic reconfigure, but when I try I get the following error:

[ERROR] [1367146343.993708402]: PointCloud, depth and visual image differ in size! Ignoring Data

If I try to visualize the rgbdcloud from the openni driver in rviz instead I get this error message:

Error updating depth cloud: Depth image size and camera info don't match: 320 x 240 vs 640 x 480(binning: 1 x 1, ROI size: 640 x 480)

So the problems seems to be the published camera info. In fact, it works just fine with vga 30hz or 25hz modality. What I have done is only setting the image_mode and depth_mode parameter to QVGA(30hz) via dynamic reconfigure, am i supposed to do something else?

I'm currently using an asus xtion pro live with rosgroovy on ubuntu 12.10.

Any advice is welcome! Thank you in advance.


Originally posted by Alex2309 on ROS Answers with karma: 163 on 2013-04-28

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hi Alex, I've played around with QVGA and also had the problem with the wrong camera info. I think I included some hack to workaround this, but the support for qvga resolution in rgbdslam may be a bit brittle and require fiddling with the settings as I didn't test it much. I am interested in the related bug reports though.

Anyway, the first error you get is because you do not change both images (rgb+depth) to qvga, but just one of them.

Edit:

I checked and I don't get that error. However, I do have problems changing to qvga while everything runs, so I start roslaunch openni_launch openni.launch, then use dynamic reconfigure to switch rgb and depth to QVGA. Then I start rgbdslam (without openni).

Edit2: I've checked in a workaround for the camera_info problem. Have a look at the new launchfile "qvga-kinect+rgbdslam.launch", it should work "out of the box".


Originally posted by Felix Endres with karma: 6468 on 2013-04-28

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by Alex2309 on 2013-04-28:
Hi, thank you for the reply. So right now there's no way to use lower resolution for the slam process?

For the first error i setted both image_mode and depth_mode to the same resolution, but i get the same error anyway

Edit: thank you with the new lauchfile works just fine!!

Comment by Felix Endres on 2013-05-01:
You're welcome. Interestingly I noticed that for qvga surf is faster than siftgpu. Might depend on the graphics card and driver though.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.