0
$\begingroup$

Rosanswers logo

hi guys, i'm trying to install depthimage_to_laserscan stack by writing

git clone "git link that i cannot post"

cd depthimage_to_laserscan

rosmake

[ rosmake ] rosmake starting...
[ rosmake ] No package specified. Building ['depthimage_to_laserscan']
[ rosmake ] Packages requested are: ['depthimage_to_laserscan']
[ rosmake ] Logging to directory /home/d4n/.ros/rosmake/rosmake_output-20130420-144925
[ rosmake ] Expanded args ['depthimage_to_laserscan'] to: ['depthimage_to_laserscan']
[rosmake-0] Starting >>> depthimage_to_laserscan [ make ]
[rosmake-0] Finished <<< depthimage_to_laserscan ROS_NOBUILD in package depthimage_to_laserscan No Makefile in package depthimage_to_laserscan [ rosmake ] Results:
[ rosmake ] Built 1 packages with 0 failures.
[ rosmake ] Summary output to directory
[ rosmake ] /home/d4n/.ros/rosmake/rosmake_output-20130420-144925

but it says

then trying to "rosrun"

rosrun depthimage_to_laserscan depthimage_to_laserscan image:=/camera/dept/image_raw

says:

[rospack] Error: stack/package depthimage_to_laserscan not found

I don't know what I'm doing wrong

I know that probably could be a simple things that I forgot to do.

thank a lot for any help

EDIT 1: thanks everybody

i tried as suggested

cd ~/my_ros_directory_thats_in_ROS_PACKAGE_PATH

git clone -b fuerte-devel https://github.com/ros-perception/depthimage_to_laserscan.git

rospack profile

rosmake depthimage_to_laserscan

it results

Failed to invoke /opt/ros/fuerte/bin/rospack deps-manifests depthimage_to_laserscan [rospack] Error: package/stack depthimage_to_laserscan depends on non-existent >package sensor_msgs

then following this http://answers.ros.org/question/12715/how-do-i-install-sensor_msgs-package/

the shell tell me

ros-fuerte-common-msgs is already the newest version.

so, I will migrate to groovy or there is still something to try?

EDIT 2: after a lot of trying I move to groovy and the stack work pretty well.

Thanks for helping me


Originally posted by danielq on ROS Answers with karma: 181 on 2013-04-20

Post score: 1


Original comments

Comment by Jon Stephan on 2013-04-20:
Did you do this all in a directory which is in your ROS package path? (echo $ROS_PACKAGE_PATH to see what the path is.)

Comment by danielq on 2013-04-20:
yep, I exported the path by typing: export ROS_PACKAGE_PATH=/home/user/ros/ros-pkg:/home/d4n/depthimage_to_laserscan

Comment by Chad Rockey on 2013-04-21:
Oh, and don't forget to always export ROS_PACKAGE_PATH=/home/user/ros/ros-pkg:/home/d4n/depthimage_to_laserscan:$ROS_PACKAGE_PATH since you want to append the variable, not replace it.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

This is a catkin package, not rosmake.

http://www.ros.org/wiki/catkin/Tutorials

Also, likely what is easier:

sudo apt-get install ros-groovy-depthimage-to-laserscan

For fuerte (and rosmake), besides my recommendation to update to Groovy, you could run pointcloud_to_laserscan from ros-groovy-turtlebot-apps OR do the following:

cd ~/my_ros_directory_thats_in_ROS_PACKAGE_PATH
git clone -b fuerte-devel https://github.com/ros-perception/depthimage_to_laserscan.git
rospack profile
rosmake depthimage_to_laserscan

Originally posted by Chad Rockey with karma: 4541 on 2013-04-21

This answer was ACCEPTED on the original site

Post score: 4


Original comments

Comment by danielq on 2013-04-23:
I tried pointcloud_to_laserscan without great results, so I decide to try depthimage_to_laserscan

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.