0
$\begingroup$

Rosanswers logo

Hello

Hello Im trying to create a map from a bag file using the gmapping. I have done everything using the tutorial http://www.ros.org/wiki/slam_gmapping/Tutorials/MappingFromLoggedData but when I tried to save the map with the map server it was just waited for the map and nothing happened. My bag file has camera, imu, laser scans and odometry .

The output of command of rxbag is

camera/depth/image lse_xsens_mti/xsens/imu/data odom scan

My launch file is

   launch>
        
        <param name="/use_sim_time" value="true"/>
        
        <node name="rosplay" pkg="rosbag" type="play" args="/home/2013-01-11-15-47-56.bag  --clock"/>
            <node pkg="tf" type="static_transform_publisher" name="baselink_laser" args="0 0 0 0 0 0 /base_link /laser 10"/>
        
        
            <node pkg="gmapping" type="slam_gmapping" name="slam_gmapping" output="screen">
            <param name="base_frame" value="base_link"/>
                <param name="odom_frame" value="base_link"/>
            <param name="map_frame" value="map"/>
        
        </node>
    
        <!-- Start an rviz node with a custom configuration for the viewpoint, map_server, trajectory, laser scans, etc -->
        <node pkg="rviz" type="rviz" output="screen" name="rviz" args="-d $(find pow_analyzer)/launch/pow_rviz.vcg"/>
    
    </launch>

Any help?

Originally posted by Astronaut on ROS Answers with karma: 330 on 2013-04-17

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

You configured the odom_frame as base_link. That should be odom instead (or whatever frame your odometry is in). As it is gmapping won't get any movements.


Originally posted by dornhege with karma: 31395 on 2013-04-18

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Astronaut on 2013-04-18:
ok. thanks. now its working

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.