Rosanswers logo

I performed a update of my package based ROS installation yesterday (12.04, groovy, AMD64) and tried to start a roscore today, which results in the following output:

kohlbrecher@opstation:~$ roscore
WARNING: unable to configure logging. No log files will be generated
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is 
  File "/opt/ros/groovy/lib/python2.7/dist-packages/rosmaster/main.py", line 73, in rosmaster_main
  File "/opt/ros/groovy/lib/python2.7/dist-packages/rosmaster/main.py", line 57, in configure_logging
    _log_filename = rosgraph.roslogging.configure_logging('rosmaster', logging.DEBUG, filename=filename)
  File "/opt/ros/groovy/lib/python2.7/dist-packages/rosgraph/roslogging.py", line 105, in configure_logging
    logging.config.fileConfig(config_file, disable_existing_loggers=False)
  File "/usr/lib/python2.7/logging/config.py", line 78, in fileConfig
    handlers = _install_handlers(cp, formatters)
  File "/usr/lib/python2.7/logging/config.py", line 153, in _install_handlers
    klass = _resolve(klass)
  File "/usr/lib/python2.7/logging/config.py", line 88, in _resolve
    found = __import__(used)
  File "/opt/ros/groovy/lib/python2.7/dist-packages/rospy/__init__.py", line 49, in 
    from .client import spin, myargv, init_node, \
  File "/opt/ros/groovy/lib/python2.7/dist-packages/rospy/client.py", line 59, in 
    import rospy.impl.init
  File "/opt/ros/groovy/lib/python2.7/dist-packages/rospy/impl/init.py", line 107, in 
    class RosStreamHandler(rosgraph.roslogging.RosStreamHandler):
AttributeError: 'module' object has no attribute 'RosStreamHandler'
[master] process has died [pid 2686, exit code 1, cmd rosmaster --core -p 11311 __log:=/home/kohlbrecher/.ros/log/e4297ce0-9d04-11e2-8192-9439e59a9133/master.log].
log file: /home/kohlbrecher/.ros/log/e4297ce0-9d04-11e2-8192-9439e59a9133/master*.log
ERROR: could not contact master [http://opstation:11311/]
[master] killing on exit

I also have fuerte installed and fuerte's roscore starts up fine.

I'm not aware of any changes on my part that could be responsible. OTOH I'd expect ROS Answers to be full of complaints if this happened to everyone. Any hints on how to solve the problems are appreciated.

/edit: Errors about 'module' having no 'RosStreamHandler' attribute also appear in other python code besides roscore (for the moment using the fuerte master with groovy nodes)

Originally posted by Stefan Kohlbrecher on ROS Answers with karma: 24361 on 2013-04-03

Post score: 1

Original comments

Comment by dornhege on 2013-04-04:
I'm running on Natty/11.10, AMD64 and just updated groovy. roscore starts fine. It's not exactly the same, so it must be something specific.

Comment by inflo on 2013-04-04:
hi, i updated today fuerte and cant start roscore. It fails with:


2 Answers 2


Rosanswers logo

I had your exact same problem, i simply upgraded my ubuntu 12.10 groovy packages to the very last version and now everything works fine again

Originally posted by radisc with karma: 61 on 2013-04-04

This answer was NOT ACCEPTED on the original site

Post score: 3


Rosanswers logo

Indeed solved after updating again. I had to

sudo apt-get dist-upgrade


sudo apt-get upgrade

didn't do it.

Originally posted by Stefan Kohlbrecher with karma: 24361 on 2013-04-04

This answer was ACCEPTED on the original site

Post score: 2


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.