0
$\begingroup$

Rosanswers logo

I'm am trying to build gmapping from source and for some reason it's not building the executables....

In a rosbuild workspace I used:

rosws set slam_gmapping --git [email protected]:dawonn/slam_gmapping.git
rosws update gmapping
source ./setup.bash
roscd gmapping
rosmake

[rosmake-0] Starting >>> gmapping [ make ]
[rosmake-0] Finished <<< gmapping [SKIP] No rule to make target None

$ rosrun gmapping slam_gmapping

[rosrun] Couldn't find executable named slam_gmapping below /home/dereck/rosbuild_ws/slam_gmapping/gmapping

rosrun gmapping < tab > < tab >

libconfigfile.so liblog.so libsensor_base.so libsensor_range.so test_map.py
libgridfastslam.so libscanmatcher.so libsensor_odometry.so libutils.so

Any idea what I'm doing wrong here?

Thanks!


Originally posted by Dereck on ROS Answers with karma: 1070 on 2013-03-24

Post score: 0


Original comments

Comment by joq on 2013-03-24:
It's hard to tell what version of that repository to use. The master branch has a different commit signature than what looks like the latest release, tagged slam_gmapping-1.2.7. You might try that one.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

after running rosmake:

roscd gmapping
cd build
make

Originally posted by Dereck with karma: 1070 on 2013-03-24

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.