0
$\begingroup$

Rosanswers logo

Hello everybody,

I'm using the Rviz MoveIt Plugin for my 6 Dof - Robot. I created the necessary package via "Moveit Setup Assistant". Unfortunately the interactive markers don’t show up. (see this threat) So I started the Joint_State_Publisher with the "GUI"-parameter on true.

But the slide controls have no influence on my robot. But it shows exactly 5 slide controls for my 5 joints, as described in my urdf.

Questions:

  1. Do I have to start the joint_state_publisher also with the "robot_description"-parameter?
  2. Do I also need to start the "robot_state_publisher"?

Sorry but I'm a quiet newby at this stuff. What information do you need in order to help me?

Many Thanks in advance viovio


Originally posted by viovio on ROS Answers with karma: 117 on 2013-03-11

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

For the interactive markers to work you need TF to be published and and end-effector to be defined. The TF is done for you as an example if you run demo.launch (latest version of the setup assistant generates that as well) or if you are running gazebo/running on the actual robot. The end-effector needs to be part of the SRDF, but I am actually working on removing this requirement.


Originally posted by isucan with karma: 1055 on 2013-03-18

This answer was ACCEPTED on the original site

Post score: 2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.