0
$\begingroup$

Rosanswers logo

Hi, I'm a newbee in ROS and tried several methods in installing ROS-Groovy-Desktop-Full in my ubuntu system without having really success. My system is Kubuntu 12.04, 3.2.0-39-generic. 64bit (not a vmware image)

I did the step due to: ...ros.org/wiki/groovy/Installation/Source sudo apt-get install python-rosdep python-wstool build-essential --> worked, ok sudo rosdep init, rosdep update --> worked, ok mkdir ~/ros_catkin_ws, cd ~/ros_catkin_ws --> worked, ok wstool init -j8 src ...packages.ros.org/web/rosinstall/generate/raw/groovy/desktop-full --> worked, ok sudo rosdep install --from-paths src --ignore-src --rosdistro groovy -y --> worked, ok

sudo ./src/catkin/bin/catkin_make_isolated --install --> BROKEN

==> Processing plain cmake package: 'bfl' Makefile exists, skipping explicit cmake invocation... ==> make cmake_check_build_system in '/home/martin/ros_catkin_ws/build_isolated/bfl' ==> make -j4 -l4 in '/home/martin/ros_catkin_ws/build_isolated/bfl' ==> make install in '/home/martin/ros_catkin_ws/build_isolated/bfl' ==> Generating an env.sh <== Failed to process package 'bfl': 'NoneType' object has no attribute 'rfind' Command failed, exiting.

I tried the package way of installation:

martin@quadcore:~/ros_catkin_ws$ sudo apt-get install ros-groovy-desktop-full[sudo] password for martin: Paketlisten werden gelesen... Fertig Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass Sie eine unmögliche Situation angefordert haben oder, wenn Sie die Unstable-Distribution verwenden, dass einige erforderliche Pakete noch nicht erstellt wurden oder Incoming noch nicht verlassen haben. Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten: ros-groovy-desktop-full : Hängt ab von: ros-groovy-navigation-tutorials (= 0.1.1-s1362460629~precise) soll aber nicht installiert werden Hängt ab von: ros-groovy-slam-gmapping (= 1.2.7-s1362457898~precise) soll aber nicht installiert werden Hängt ab von: ros-groovy-navigation (= 1.10.2-s1362453401~precise) soll aber nicht installiert werden E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Not possible because of broken packages

Does anybody have an idea, or could this be a bug in the installion processing script.

Hint: A Fuerte installation in a LUbuntu VMWare worked, but I had to copy manually some deb files from the directory. The problem was: a +-00000.deb file was shown, downloaded i had a ...+ 00000.deb file. Renaming this into +-0000.deb and copying into var/cache/apt the the installation worked.

I think that the installation process is no so clean as it should be. A lot of work to do on this place.

thanks, martin


Originally posted by MartinHummel on ROS Answers with karma: 156 on 2013-03-09

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hello,

after a terrible installation process it seems to work:

Using Kubuntu 12.04 3.2.0-39-generic. 64bit base installation:

  • Open Muon or another paket manager
  • Install the paket ros-groovy-ros-full (this includes the ros-groovy documentation)
  • Install ros-groovy-visualisation

Then proceed the steps according the tutorial. If ROS_WORKSPACE is not defined (you see it using roscd) than add at the end of .bashrc the following lines:

export ROS_PACKAGE_PATH=~/catkin_ws:$ROS_PACKAGE_PATH export ROS_WORKSPACE=~/catkin_ws

(if you are using the catkin make process)


Originally posted by MartinHummel with karma: 156 on 2013-03-10

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.