Rosanswers logo

I am following the tutorial "Visualizing TurtleBot Kinect Data", but I cannot see the data from camera...

roslaunch turtlebot_bringup kinect.launch

it gives:

[ INFO] [1362547950.940390473]: [/openni_camera] Number devices connected: 1
[ INFO] [1362547950.940926034]: [/openni_camera] 1. device on bus 001:10 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'A00367910023104A'
[ WARN] [1362547950.950968862]: [/openni_camera] device_id is not set! Using first device.
[ INFO] [1362547951.051461572]: [/openni_camera] Opened 'Xbox NUI Camera' on bus 1:10 with serial number 'A00367910023104A'
[ INFO] [1362547951.114948505]: rgb_frame_id = 'camera_rgb_optical_frame' 
[ INFO] [1362547951.127139480]: depth_frame_id = 'camera_depth_optical_frame' 

Then on the Workstation, I type:

rosrun rviz rviz

Add camera -> Image Topic -> whatever...

The rviz window shows No Image

And the terminal shows Dropped 100% of messages

Closing rviz, now on the Laptop, I try:

rosrun image_view image_view image:=/camera/rgb/image

It just shows a gray window.

Anyone has any idea what is wrong?

TurtleBot (Kinect, iRobot Create); Ubuntu 10.04; ROS Electric

Please help me!! Thank you very much.

More information: (1) the Kinect shows a flashing green light (not solid light); (2) in rviz, under camera, it says Global Status: Error. Inside it says ... No Transform.

Originally posted by Chik on ROS Answers with karma: 229 on 2013-03-05

Post score: 0


1 Answer 1


Rosanswers logo

This problem is solved.

The solution is a bit mysterious... In Rviz, the default setting is Global Options -> Fixed Frame -> base_link and Target Frame -> < Fixed Frame >

This setting is correct, but in order to make it work, I need to click them and select them again, and then reboot the workstation and the laptop. I don't know why but it works after then.

In addition, the distributor told me that the flashing (not solid) green light on Kinect is normal.

Originally posted by Chik with karma: 229 on 2013-03-10

This answer was ACCEPTED on the original site

Post score: 0


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.