0
$\begingroup$

Rosanswers logo

Hello,

I am using a Turtlebot2 with groovy. I am trying to follow the 3D visualization tutorial in Turtlebot tutorials but when I want to visualize things in rviz I have the image of the kinect but no depth data and no laser scan. I don't have any error message in rviz, but nothing appears on the screen.

The problem is that when I connect the kinect to my desktop computer and not to the turtlebot's laptop (and use the same launch files) everything is working fine.

Do you have some clues ?

Caroline


Originally posted by CarolineQ on ROS Answers with karma: 395 on 2013-03-05

Post score: 0


Original comments

Comment by prasanna.kumar on 2013-03-05:
hi, I am working on turtlebot2 too. I see that you have successfully setup the robot. Basically, I am having troubles setting up the robot. Could I use your help please ? Could you give me your e-mail id or something by which I could communicate with you ? Mine is [email protected].

Comment by jorge on 2013-03-05:
Please check that you are not plugging the Kinect in a USB 3.0 port. Most modern laptops come with one or two 3.0, and Kinect is incompatible with them.

Comment by bit-pirate on 2013-03-05:
@prasanna.kumar if you need help beyond ROS answers, feel free to join the Turtlebot mailing list ([email protected]) or join the ROS chat room on IRC (http://www.ros.org/wiki/Get%20Involved#IRC).

Comment by Lucile on 2013-06-10:
Hi ! I see that we've been through the same issues. I had this problem too and didn't manage to fix it. Did you find a solution ?

Comment by CarolineQ on 2013-06-10:
I had this problem some time ago. I installed Openni and SensorKinect from source (OpenNI-Bin-Dev-Linux-x86-v1.5.4.0, Sensor-Bin-Linux-x86-v5.1.2.1) and updated my packages and everything works now.

Comment by Herick on 2013-11-11:
CarolineQ, can you help me? please! I tried to install openni and sensorkinect based on http://ramsrigoutham.com/2012/07/08/getting-started-with-kinect-on-ubuntu-12-04-openni-nite-simpleopenni-and-processing/ however, rviz still doesn't work. My e-mail: [email protected].

Comment by CarolineQ on 2013-11-11:
Hi Herick. I have a new computer on which I am also unable to make Rviz work well. It's probably the same problem but I don't have any idea of how to make it work... Sorry.

Comment by tfoote on 2013-11-12:
@Herick Please open a new question, this one is quite old.

Comment by Herick on 2013-11-12:
Thank you anyway. @CarolineQ

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Your issue might be into this problem also: https://github.com/turtlebot/turtlebot/issues/57


Originally posted by Daniel Stonier with karma: 3170 on 2013-03-06

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.