0
$\begingroup$

Rosanswers logo

Updated: I removed everything from the turtlebot laptop and installed Ubuntu 12.04, installed ros-groovy-desktop and went through debs installation for the TurtleBot.

  1. I do not get errors with bringup now but I get this warning

    process[app_manager-11]: started with pid [6649] [WARN] [WallTime: 1362386890.272856] Battery : unable to check laptop battery info [/proc/acpi/battery/BAT0 does not exist] [WARN] [WallTime: 1362386890.277911] Battery : unable to check laptop battery state [/proc/acpi/battery/BAT0 does not exist].

  2. Now, the dashboard looks like this

image description

With tele-op, it is still the same. I am not able to move it around. The controls do not work.

The kuboki base doesn't seem to be recognized. Why is that ? Is there a mistake I am doing ?

Thanks, Prasanna.


Originally posted by prasanna.kumar on ROS Answers with karma: 1363 on 2013-02-28

Post score: 0


Original comments

Comment by jorge on 2013-03-04:
Can you you see the robot green LED? Sorry, I know this sounds like a stupid question, but Kobuki has a switch to change between firmware updates (no LED) and normal running. Maybe your switch is on "download" mode.

Comment by jorge on 2013-03-04:
And another basic thing to check is whether port /dev/kobuki exists when the robot is plugged (don't need to be on)

Comment by Daniel Stonier on 2013-03-04:
The warning is probably because you are using a different laptop than the default the turtlebot is configured for. There is some information about netbook batteries on the wiki: http://ros.org/wiki/turtlebot/Tutorials/groovy/Netbook%20Battery%20Setup

Comment by prasanna.kumar on 2013-03-04:
@jorge The switch is in "operation" mode only and /dev/kobuki does not exist. What may be the problem ?

Comment by prasanna.kumar on 2013-03-05:
@Daniel Stonier under /proc/acpi there is nothing named battery. So basically there is no /proc/acpi/battery.

Comment by jorge on 2013-03-05:
Did you execute this command after installation? rosrun kobuki_ftdi create_udev_rules (you will need root password; and upgrade ros-groovy-kobuki if the script is missing)

Comment by prasanna.kumar on 2013-03-06:
@Daniel Stonier Thanks! I guess that should work once tag bug is fixed. And, I am sorry if this sounds too naive, how do I edit a ros wiki page?

Comment by prasanna.kumar on 2013-03-07:
@Daniel Stonier I tried setting the battery to /sys/class/power_supply/BAT0 but now I am getting a warning tha /sys/class/power_supply/BAT1/info is missing.

Comment by Daniel Stonier on 2013-03-10:
Just create an account for the wiki and you can start editing pages. Are you sure you set BAT0 (not BAT1) correctly?

Comment by Chik on 2013-03-13:
If I were you, I would contact the distributor (Clearpath?) and ask them to send a guy to your lab to fix everything.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Is http://askubuntu.com/questions/214379/where-did-proc-acpi-battery-bat0-xxx-go-in-12-10 relevant for you? If that works, update the battery setup wiki page with a hint and ticket us at https://github.com/turtlebot/turtlebot/issues?state=open


Originally posted by Daniel Stonier with karma: 3170 on 2013-03-06

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.