0
$\begingroup$

Rosanswers logo

Running step 2.1.3 Building the catkin Workspace of http://www.ros.org/wiki/groovy/Installation/OSX/Homebrew/Source produces the following error (on OS X 10.8.2). It looks like it's a problem interfacing with BOOST?

[ 88%] Building CXX object CMakeFiles/draw_square.dir/tutorials/draw_square.cpp.o
usr/local/Cellar/boost/1.53.0/include/boost/type_traits/detail/has_binary_operator.hp:50: Parse error at "BOOST_JOIN"
make[2]: *** [include/turtlesim/moc_turtle_frame.cxx] Error 1
make[1]: *** [CMakeFiles/turtlesim_node.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
Linking CXX executable /Users/alex/ros_catkin_ws/devel_isolated/turtlesim/lib/turtlesim/turtle_teleop_key
[ 88%] Built target turtle_teleop_key
Linking CXX executable /Users/alex/ros_catkin_ws/devel_isolated/turtlesim/lib/turtlesim/mimic
[ 88%] Built target mimic
Linking CXX executable /Users/alex/ros_catkin_ws/devel_isolated/turtlesim/lib/turtlesim/draw_square
[ 88%] Built target draw_square
make: *** [all] Error 2

 /opt/ros/groovy/env.sh make -j8 -l8

Command failed, exiting.

Any suggestions, people? Thanks in advance.


Originally posted by Noldorin on ROS Answers with karma: 161 on 2013-02-22

Post score: 3


Original comments

Comment by Hansg91 on 2013-02-23:
I am using boost 1.49 on OSX, which is what I believe Groovy is build for, you can try that out but I am not sure if it will work ...

Comment by Noldorin on 2013-02-24:
@Hansg91: I could try that yeah, although I'd prefer the latest version of Boost be available (via brew) normally...

Comment by Noldorin on 2013-02-24:
I seem to have isolated the error: https://bugreports.qt-project.org/browse/QTBUG-22829. Will report back soon!

Comment by joq on 2013-02-25:
Safer to use the boost version ROS was built and tested with.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

This has already been fixed in source:

https://github.com/ros/ros_tutorials/pull/6

UPDATE:

To get ros_tutorials from source into your workspace:

$ cd /path/to/your/workspace
$ rm -rf src/ros_tutorials src/roscpp_tutorials src/rospy_tutorials src/turtlesim
$ cd src
$ git clone https://github.com/ros/ros_tutorials.git
$ cd ..
$ catkin_make_isolated --install

That should get the ros_tutorials packages from source. (this may or may not work if there have been breaking changes in other packages which affect ros_tutorials)


Originally posted by William with karma: 17335 on 2013-02-25

This answer was ACCEPTED on the original site

Post score: 4


Original comments

Comment by Noldorin on 2013-02-25:
Okay, that's great. How do I install from source though? Are their instructions parallel to the ones I linked to above?

Comment by William on 2013-02-25:
You'll have to remove the packages affected from your workspace and fetch them from source instead. Currently there isn't any easy way to do this. I'll update my answer with instructions.

Comment by Noldorin on 2013-02-25:
Thanks @William. I'll give that a go now and report back.

Comment by 130s on 2013-03-25:
@William that might be the case with me. After I cloned ros_tutorials, I still got stuck at "Failed to process package 'roscpp_tutorials'". Removing the entire ros_tutorials worked it around. Then I cloned it again but same problem.

Comment by hawesie on 2013-05-22:
It seems like @William's update moved the location of 'roscpp_tutorials' which causes the rebuild to fail. I had to 'rm -rf build_isolated' before running the build command for it to work. There is probably a less nuclear option, but that worked for me.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.