0
$\begingroup$

Rosanswers logo

Hi,

I have been trying to install ROS Groovy Mobile on my RPi. I keep getting an error when I run sudo rosdep install --from-paths src --ignore-src --rosdistro groovy -y which returns ERROR: the following rosdeps failed to install apt: command [sudo apt-get install -y python-rospkg] failed

Any ideas how to get around this? I cannot install the package at all. I commented out the dependency in roslib.

Anyone have an image of ROS Groovy Mobile or Full installed on Raspbian?


Originally posted by tonybaltovski on ROS Answers with karma: 2549 on 2013-02-19

Post score: 2

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

good news, there is exactly what you ask for

push this link hard!

Have fun with it :)


Originally posted by kalectro with karma: 1554 on 2013-02-19

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by tonybaltovski on 2013-02-20:
That was the guide I was using. I cannot get past 5.6 due to the error above. Were you able to install it?

Comment by kalectro on 2013-02-20:
Yes and I also posted an image file on the very top of the tutorial ;) There is a red box right under the command which tells you that this command will fail and how to fix it

Comment by tonybaltovski on 2013-02-20:
Sorry I did not notice the link. Thank you so much for that. I edited many package.xml that contained python-rospkg but it still fails. I will try the image now. Thank you again. I'd still like to be able to install from source but I'll try that in my spare time.

Comment by kalectro on 2013-02-20:
I added the robust option for rosdep (-r) which should give you a summary of all packages which have not been installed successfully at the end. If there is no ERROR and only some apt-get commands which were not found, you will be fine and can go on with the tutorial. Feel free to edit it as well

Comment by tonybaltovski on 2013-02-21:
Thank you. I just tried the image and it works perfectly. I will try to compile it from source another time. Your help with much appreciated.

Comment by tonybaltovski on 2013-02-23:
@kalectro Do you use the RPi as the master or another laptop? I configured my laptop as the masters for my RPi. I can see the rostopic list but I cannot echo any topics. When I try to use a simple command to publish such as rostopic pub /test std_msgs/Int32 300, I can see it locally on the PRi.

Comment by tonybaltovski on 2013-02-23:
Any ideas? (Sorry I ran out of characters)

Comment by kalectro on 2013-02-23:
It will also work with a master running somewhere else. The issue you have might be due to your DNS. Try setting ROS_IP, that should work

Comment by tonybaltovski on 2013-02-24:
I set the ROS_IP in the .bashrc but it still does not work. I can see the topic but cannot echo it. Do I need to run any commands after I write the image to the SD to initialize ROS?

Comment by kalectro on 2013-02-24:
no, ROS should work out of the box. Did you set ROS_IP on the raspberry pi and the laptop? I would not recommend setting it in the bashrc file because the address could change. Just to be clear... set ROS_IP to the IP of the respective device. Find it out using ifconfig

Comment by tonybaltovski on 2013-02-25:
I set the ROS_IP correctly and I confirmed by echo $ROS_IP. I set it in the bashrc since all my interfaces are static for now. The communication is there between the two but the RPi can publish or echo topics but I can see the topics even new ones created on the master laptop.

Comment by tonybaltovski on 2013-02-25:
Do you use the GUI on this image? I cannot get the USB devices to work once I boot the GUI using startx but once I use a original image they work fine.

Comment by kalectro on 2013-02-25:
no, I did not try any gui on the Raspi

Comment by tonybaltovski on 2013-02-27:
@kalectro I saw your post on the Raspi forum and thought maybe something could be corrupt with the image I downloaded. Do you mind posting the md5sum for the image? By the way, did you compile all the ROS stuff for the Raspi yourself?

Comment by kalectro on 2013-02-28:
I do not have the original image on my computer anymore, sorry. What you could try is downloading my previously uploaded image from here http://goo.gl/0yoT8 And yes, I compiled everything from source using a chroot environment. I wrote everything down in the wiki

Comment by tonybaltovski on 2013-02-28:
Thanks Kalectro, it worked. I just needed to at my master as a host in /etc/hosts with that last image. Thanks for doing all the work of compiling everything and posting the image. In addition, thank you for all your help.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.