0
$\begingroup$

Rosanswers logo

hi, this is my error. any body help me plz? :)

mohsen@mohsen-ThinkPad-R500:~$ rosdep install turtle_tf rviz

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: turtle_tf: Missing resource catkin

ROS path [0]=/opt/ros/fuerte/share/ros

ROS path [1]=/home/mohsen/fuerte_workspace

ROS path [2]=/opt/ros/fuerte/share

ROS path [3]=/opt/ros/fuerte/stacks


Originally posted by Mohsen Hk on ROS Answers with karma: 139 on 2013-02-18

Post score: 0


Original comments

Comment by dornhege on 2013-02-18:
What do you get for rosdep db | grep catkin?

Comment by 130s on 2013-02-18:
@Mohsen Hk Btw, I have a feeling that turtle_tf might not require to be rosdep install although the tutorial says to do so. Can you skip that part and see what happens?

Comment by dornhege on 2013-02-18:
That's probably true. Should still work, though!

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

catkin isn't installed in your machine.

Install it with necessary ROS distro http://www.ros.org/wiki/catkin I haven't tried on fuerte but try:

% sudo apt-get install ros-fuerte-catkin

Originally posted by 130s with karma: 10937 on 2013-02-18

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Ameer Hamza Khan on 2016-01-19:
I am getting same error with

roslisp: Missing resource geneus

How to solve this?

Comment by 130s on 2016-01-19:
@Ameer Hamza Khan Please open a new question. Comment section is not designed for new questions (and it doesn't get as much attention as you want).

Comment by Ameer Hamza Khan on 2016-01-20:
@130s I have opened already opened a new question here http://answers.ros.org/question/224521/roslisp-missing-resource-geneus/

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.