0
$\begingroup$

Rosanswers logo

System description: Ubuntu 11.10, 64-bit, ROS Fuerte, RGBDSLAM installed/compiled, openni_camera/openni_launch installed

My goal right now is to generate a point cloud via a robot, running RGBDSLAM in headless mode, so that I can offload the *.pcd files to a remote server for additional CV processing.

I am able to run RGBDSLAM and initialise/start/pause the capture process, using the commands described here:

ros.org/wiki/rgbdslam#USAGE_without_GUI

In fact, my problem is identical to the one described in the following thread:

answers.ros.org/question/12886/problem-capturing-rgbdslam-pointcloud-data-in-headless-mode/

When I finally attempt to save the point cloud that I thought I was capturing, I receive the following output:

[ INFO] [1360639708.445177201]: Pause toggled to: false [ INFO] [1360639708.445773087]: Processing. [ INFO] [1360639754.545821492]: Saving Whole Model to quicksave.pcd [ INFO] [1360639754.546213301]: Saving all clouds to quicksave.pcd, this may take a while as they need to be transformed to a common coordinate frame. Qt Concurrent has caught an exception thrown from a worker thread. This is not supported, exceptions thrown in worker threads must be caught before control returns to Qt Concurrent. terminate called after throwing an instance of 'pcl::IOException' what(): [pcl::PCDWriter::writeBinary] Input point cloud has no data! ================================================================================REQUIRED process [rgbdslam-2] has died! process has died [pid 31838, exit code -6, cmd /home/magnate/ros/rgbdslam_freiburg/rgbdslam/bin/rgbdslam __name:=rgbdslam __log:=/home/magnate/.ros/log/1e2990da-74a4-11e2-9f9c-4ce676913015/rgbdslam-2.log]. log file: /home/magnate/.ros/log/1e2990da-74a4-11e2-9f9c-4ce676913015/rgbdslam-2*.log

I started this thread because I am still experiencing this issue even after I hardcode the store_pointclouds directive to true in my rgbdslam/launch/headless.launch file (answer #1) and make sure that the openni driver is running before I engage RGBDSLAM-headless (answer #2) ... and because I'm unable to comment on that other thread right now..

I have also tried adapting the published camera data topics in my openni launch file and the headless.launch file, as suggested here

answers.ros.org/question/31690/rgbdslam-gui-not-getting-data-from-kinect/

And I successfully enable default registration of depth and color, via dynamic_reconfigure, as suggested here:

answers.ros.org/question/11939/activating-openni-depth-registration-by-default/

Regardless of what I try, however, I am still unable to save point clouds. If anyone has any suggestions, I'd love to hear them!


Originally posted by magnate on ROS Answers with karma: 28 on 2013-02-12

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I'm going to investigate this issue when I have a bit more time, but I have since mirrored the rgbdslam framework on two other systems, without issue. Thus, it appears to be a driver issue on the original system (Foxconn D270S mini-atx, with a fresh install of Ubuntu 11.10)


Originally posted by magnate with karma: 28 on 2013-02-15

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.