0
$\begingroup$

Rosanswers logo

i get the error below when i run: roslaunch openni_launch openni.launch depth_registration:=true

[ INFO] [1360504277.554280357]: Searching for device with index = 1 nodelet: /usr/include/boost/smart_ptr/shared_ptr.hpp:412: boost::shared_ptr::reference boost::shared_ptr::operator*() const [with T = xn::NodeInfo, boost::shared_ptr::reference = xn::NodeInfo&]: Assertion `px != 0' failed. [camera_nodelet_manager-1] process has died [pid 9117, exit code -6, cmd /opt/ros/fuerte/stacks/nodelet_core/nodelet/bin/nodelet manager __name:=camera_nodelet_manager __log:=/home/bot/.ros/log/3dd4e5a0-7388-11e2-8705-00187d252393/camera_nodelet_manager-1.log]. log file: /home/bot/.ros/log/3dd4e5a0-7388-11e2-8705-00187d252393/camera_nodelet_manager-1*.log

please let me know how to correct- thanks


Originally posted by ap on ROS Answers with karma: 42 on 2013-02-10

Post score: 0


Original comments

Comment by ap on 2013-02-11:
using openni.launch so tried the killallXnSensorServer cmd. it worked. thank you.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Try typing this command in the same terminal where you get this error killall XnSensorServer. then try launching the node again. If the process dies again, ctrl+c and then type the killall command again (it should say no processes found). Then try launching the node again.


Originally posted by K_Yousif with karma: 735 on 2013-02-10

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by shray on 2013-06-08:
I had the same nodelet-manager dying error and this worked straight away for me. Thanks. It would be helpful for me if you also pointed me to why this worked.

Comment by K_Yousif on 2013-06-23:
I'm glad it worked for you. I am not exactly sure why it works. It just does :)

Comment by Pototo on 2016-09-28:
Like @ayush_dewan said about memory allocation. When you don't shut down properly, then you have multiple processes trynna access the camera...hence it crashes.

Comment by Pototo on 2016-09-28:
You can reproduce the error by launch and shutting down over and over, till you notice that the Depth camera light is still on, even if you've shut down your openni nodes/nodeleds

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.