Rosanswers logo


Trying to install ros desktop on raspberry pi.

I am at the resolving dependencies point and the command sudo rosdep install --from-paths src --ignore-src --rosdistro groovy -y fails with ERROR: your rosdep installation has not been initialized yet. Please run: rosdep update

rosupdate runs fine, but the error still happens. Tried running rosdep init again, but get ERROR: default sources list file already exists:Please delete if you want to re-initialize

tried deleting and re-initializing, but still getting the same error

Originally posted by nickw on ROS Answers with karma: 1504 on 2013-02-07

Post score: 2


1 Answer 1


Rosanswers logo


I got this to work by running sudo rosdep update. Give it a try.

Originally posted by tonybaltovski with karma: 2549 on 2013-02-14

This answer was ACCEPTED on the original site

Post score: 1

Original comments

Comment by Dirk Thomas on 2013-02-15:
You should not run rosdep update as root since it creates the database in your user home with root ownership.

Comment by tonybaltovski on 2013-02-19:
Without root access , I was not able to update the database. Is there any reason it cannot be done without root access?


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.