0
$\begingroup$

Rosanswers logo

I just received the Turtlebot2/Kobuki. I installed ROS using the included memory stick. Now I am trying to install all of the remaining software indicated on the Kobuki Installation ROS page.

The first problem occurs because of a dead link referenced for a rosinstall under

2. RosInstall

I got around this by finding a cached version of the page online and doing a local file rosinstall.

The second problem occurred when I attempted a rosdep install kobuki_node under 3. Rosdep.

This returns the following: ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: kobuki_node: Cannot locate rosdep definition for [kobuki_safety_controller].

I ignored the error and compiled. However, I am unable to run any of the launch files to get the Kobuki up and running. I get various errors that seem to be related to the fact that rosdep install kobuki_node failed.

E.g.: When I try to bring up the Kobuki with the minimal.launch file I get the following:

[ERROR] [1360192717.868409930]: Failed to load nodelet [/mobile_base] of type [kobuki_node/KobukiNodelet]: Could not find library corresponding to plugin kobuki_node/KobukiNodelet. Make sure the plugin description XML file has the correct name of the library and that the library actually exists.
[FATAL] [1360192717.869479490]: Service call failed!
[mobile_base-2] process has died [pid 22945, exit code 255, cmd /opt/ros/groovy/lib/nodelet/nodelet load kobuki_node/KobukiNodelet kobuki mobile_base/odom:=odom mobile_base/joint_states:=joint_states __name:=mobile_base __log:=/home/turtlebot/.ros/log/5a31d5b2-70ab-11e2-aa29-485d60f58202/mobile_base-2.log].
log file: /home/turtlebot/.ros/log/5a31d5b2-70ab-11e2-aa29-485d60f58202/mobile_base-2*.log

Any suggestions will be appreciated.

Thanks!


Originally posted by guzza100 on ROS Answers with karma: 11 on 2013-02-06

Post score: 1


Original comments

Comment by bit-pirate on 2013-02-06:
"This page is full of lies" was my colleagues statement about the Kobuki installation page. :-) Please be patient, he is working on it right now and will come back to you ASAP.

Comment by jorge on 2013-02-06:
Some things are still a little in flux due to the late arrival of groovy - the live usb's and the 2.0 release are still on their way. Do you actually need to install via source? You can probably get away with just installing turtlebot groovy debs.

Comment by jorge on 2013-02-06:
Btw, the Kobuki install tutorial that used to lay is fair again. He explain how to install all Kobuki from deb packages.

Comment by guzza100 on 2013-02-08:
Thanks bit-pirate and jorge. The new installation page with the deb packages worked and i was able to start up the Turtlebot 2 and run teleop and autodocking!

Comment by bit-pirate on 2013-02-11:
Great! Looks like all your problems have been solved. Are you able to mark your question as answered even though it has no answer?

Comment by jorge on 2013-02-11:
Good to hear that! Just in case you have extra time to expend, we have added a second tutorial with instructions to install Kobuki from source code, using catkin.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I just summarize previous comments to provide a clear answer and close the question:

  • This tutorial explains how to install Kobuki from turtlebot groovy debs

  • And this other explains how to install Kobuki from source code, using catkin.


Originally posted by jorge with karma: 2284 on 2013-02-12

This answer was ACCEPTED on the original site

Post score: 2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.