0
$\begingroup$

Rosanswers logo

Dear all,

On a fresh install of ROS Groovy on Ubuntu 12.10 Quantal, there are unmet dependencies. I have verified that my sources.list.d file is properly set and updated.

I have been trying to search the root cause of this but it is not clear what I need to do.

This is what I get: vmrguser@vmrg-xps-15:~$ sudo apt-get install ros-groovy-desktop-full Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: ros-groovy-desktop-full : Depends: ros-groovy-nodelet-core (= 1.7.14-0quantal-20130126-0955-+0000) but it is not going to be installed Depends: ros-groovy-navigation-tutorials (= 0.1.1-s1359209339~quantal) but it is not going to be installed Depends: ros-groovy-filters (= 1.6.0-s1359193811~quantal) but it is not going to be installed Depends: ros-groovy-slam-gmapping (= 1.2.7-s1359207803~quantal) but it is not going to be installed Depends: ros-groovy-qt-gui-core (= 0.2.12-0quantal-20130126-0207-+0000) but it is not going to be installed Depends: ros-groovy-perception-pcl (= 1.0.26-0quantal-20130126-1140-+0000) but it is not going to be installed Depends: ros-groovy-rqt-common-plugins (= 0.2.10-0quantal-20130126-1008-+0000) but it is not going to be installed Depends: ros-groovy-pluginlib (= 1.9.17-0quantal-20130126-0115-+0000) but it is not going to be installed Depends: ros-groovy-image-pipeline (= 1.10.3-0quantal-20130126-1142-+0000) but it is not going to be installed Depends: ros-groovy-rqt-robot-plugins (= 0.2.8-0quantal-20130126-1015-+0000) but it is not going to be installed Depends: ros-groovy-image-common (= 1.10.0-0quantal-20130126-0943-+0000) but it is not going to be installed Depends: ros-groovy-common-tutorials (= 0.2.3-s1359194806~quantal) but it is not going to be installed Depends: ros-groovy-image-transport-plugins (= 1.8.17-0quantal-20130126-0958-+0000) but it is not going to be installed Depends: ros-groovy-visualization-tutorials (= 0.7.3-s1359195079~quantal) but it is not going to be installed Depends: ros-groovy-laser-pipeline (= 1.5.5-s1359203953~quantal) but it is not going to be installed Depends: ros-groovy-simulator-gazebo (= 1.7.9-s1359201147~quantal) but it is not going to be installed Depends: ros-groovy-rviz (= 1.9.20-0quantal-20130126-0940-+0000) but it is not going to be installed Depends: ros-groovy-diagnostics (= 1.7.9-0quantal-20130126-0941-+0000) but it is not going to be installed Depends: ros-groovy-navigation (= 1.10.1-s1359205612~quantal) but it is not going to be installed W: No priority (or zero) specified for pin E: Unable to correct problems, you have held broken packages.

Thanks


Originally posted by Juan on ROS Answers with karma: 208 on 2013-01-30

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Please try the solution posted here.


Originally posted by SL Remy with karma: 2022 on 2013-01-30

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.