0
$\begingroup$

Rosanswers logo

I was trying to install groovy in ubuntu 12.04 and I have a problem with dependencies. I tried to install the dependencies separately and I had no success. I already visited the forum and tried this - answers.ros.org/question/52155/how-to-install-groovy-desktop-full-on-1204/ - but it's not working either. Any ideas?

$sudo apt-get install ros-groovy-desktop-full
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-groovy-desktop-full : Depends: ros-groovy-navigation-tutorials (= 0.1.1-s1359175367~precise) but it is not going to be installed
                           Depends: ros-groovy-slam-gmapping (= 1.2.7-s1359174918~precise) but it is not going to be installed
                           Depends: ros-groovy-vision-opencv (= 1.10.3-0precise-20130125-2028-+0000) but it is not going to be installed
                           Depends: ros-groovy-perception-pcl (= 1.0.26-0precise-20130126-0228-+0000) but it is not going to be installed
                           Depends: ros-groovy-rqt-common-plugins (= 0.2.10-0precise-20130126-0231-+0000) but it is not going to be installed
                           Depends: ros-groovy-image-pipeline (= 1.10.3-0precise-20130126-0257-+0000) but it is not going to be installed
                           Depends: ros-groovy-stage (= 1.6.7-s1359157880~precise) but it is not going to be installed
                           Depends: ros-groovy-rqt-robot-plugins (= 0.2.8-0precise-20130126-0246-+0000) but it is not going to be installed
                           Depends: ros-groovy-image-transport-plugins (= 1.8.17-0precise-20130126-0212-+0000) but it is not going to be installed
                           Depends: ros-groovy-visualization-tutorials (= 0.7.3-s1359166718~precise) but it is not going to be installed
                           Depends: ros-groovy-laser-pipeline (= 1.5.5-s1359172667~precise) but it is not going to be installed
                           Depends: ros-groovy-simulator-gazebo (= 1.7.9-s1359168833~precise) but it is not going to be installed
                           Depends: ros-groovy-rviz (= 1.9.20-0precise-20130126-0133-+0000) but it is not going to be installed
                           Depends: ros-groovy-navigation (= 1.10.1-s1359173385~precise) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

multiverse reps are allowed and the ros-latest.list's value is correct, with the precise repositories. So yes, I followed the steps of the installation, but it's not working


Originally posted by silgon on ROS Answers with karma: 649 on 2013-01-30

Post score: 0


Original comments

Comment by silgon on 2013-02-01:
multiverse reps are allowed and the ros-latest.list's value is "deb http://packages.ros.org/ros/ubuntu precise main". So yes, I followed the steps of the installation, but it's not working

Comment by SL Remy on 2013-02-01:
Didn't see those sentences at the end (hope the reformatting would make them clearer to others). What happens when you sudo apt-get install ros-groovy-ros-base? If you're up for it, there's also http://www.howtoforge.com/checking-package-dependencies-with-apt-rdepends-on-debian-ubuntu

Comment by silgon on 2013-02-15:
sorry for the delay, it install that package an dependencies but when I tried sudo apt-get install ros-groovy-desktop-full it continues with the same error message.

Comment by silgon on 2013-02-18:
tried "sudo apt-get update --fix-missing" , not working either

Comment by silgon on 2013-02-18:
when I do the command with aptitude install the error is libfontconfig1-dev : Depends: libfontconfig1 (= 2.8.0-3ubuntu9.1) but 2.10.1-0ubuntu3 is to be installed

Comment by rgm on 2013-04-23:
I had this when I accidentally had the 12.10 repo in ros-latest.list when I should have had the 12.04 "precise" source. It went away after I edited ros-latest.list to ensure "precise", then sudo apt-get clean && sudo apt-get update ; sudo apt-get install ros-groovy-desktop-full.

Comment by ferre on 2013-04-29:
has anyone found a solution to this issue?

Comment by SL Remy on 2013-04-30:
Yes. If the solution didn't work for you, post a new question so you can get help.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Finally I used sudo aptitude to install it. Aptitude offers you a solution, you answer not, and after that it will offer you to downgrade a package, you select that option and voilà! At least that worked for me.


Originally posted by silgon with karma: 649 on 2013-03-06

This answer was ACCEPTED on the original site

Post score: 4


Original comments

Comment by Lucile on 2013-06-11:
This solution worked for me as well ! Thanks :)

Comment by wignode on 2013-07-28:
This initially worked for me but I stumpled upon unmet dependencies later on. I am now using the fix described by rgm.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.