1
$\begingroup$

I am new to Morse and robotics.

This code control the robot by giving the linear and angular velocity.

This is the scene description

from morse.builder import *
robot = ATRV()
motion = MotionVW()
motion.add_stream('socket')
robot.append(motion)

semanticL = SemanticCamera()
semanticL.translate(x=0.2, y=0.3, z=0.9)
robot.append(semanticL)

semanticR = SemanticCamera()
semanticR.translate(x=0.2, y=-0.3, z=0.9)
robot.append(semanticR)

motion.add_stream('socket')
semanticL.add_stream('socket')
semanticR.add_stream('socket')

env = Environment('land-1/trees')
env.set_camera_location([10.0, -10.0, 10.0])
env.set_camera_rotation([1.0470, 0, 0.7854])

and this is the control script

import pymorse
with pymorse.Morse() as simu:
    simu.robot.motion.publish({"v": 3, "w": -1})

The robot moves well. But when I remove the semantic cameras from the scene description the robot do not move. I am confused, they are just sensor, why the robot don't move ?

$\endgroup$
  • $\begingroup$ I reposted the question on github.com/morse-simulator/morse/issues/567 $\endgroup$ – djou Oct 11 '14 at 21:05
  • $\begingroup$ What is the behavior you are expecting? $\endgroup$ – Ian Oct 14 '14 at 22:35
  • $\begingroup$ move from point x to y by changing linear and angular velocity $\endgroup$ – djou Oct 15 '14 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.