0
$\begingroup$

Rosanswers logo

Hi,

I am running Ubuntu 12.10 and ROS Groovy.

lsusb shows the kinect:

Bus 002 Device 019: ID 045e:02ad Microsoft Corp. Xbox NUI Audio
Bus 002 Device 018: ID 045e:02b0 Microsoft Corp. Xbox NUI Motor
Bus 002 Device 020: ID 045e:02ae Microsoft Corp. Xbox NUI Camera

But when I run roslaunch openni_launch openni.launch, it doesn't find the kinect.

[ INFO] [1357079636.178559036]: No devices connected.... waiting for devices to be connected
[ INFO] [1357079639.179093142]: No devices connected.... waiting for devices to be connected

A week ago, after installing the updated openni package, everything worked and now I get the same "no devices connected" message even though I tried connecting it in different usb ports etc. Is this a bug or is my camera somehow broken?

Regards,

Oier


Originally posted by Oier on ROS Answers with karma: 145 on 2013-01-01

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Well, after trying everything from manually putting the devices id on the launcher file, to remove gspca_kinect (which wasn't loaded), I had the brilliant idea of reinstalling all the openni ros packages via synaptic, now it works :-)


Originally posted by Oier with karma: 145 on 2013-01-02

This answer was ACCEPTED on the original site

Post score: 4


Original comments

Comment by Dave Coleman on 2013-01-04:
I'm having similar issues and tried re-installing all the openni packages via synaptic, but when I went to re-install them it appears there are only 32bit version available at the moment. Did you have this problem? I'll try again tomorrow but it appears there is a debian issue.

Comment by Oier on 2013-01-04:
What version of Ubuntu are you using? I have 12.10 and the openni packages installed are 64 bits architecture.

Comment by Dave Coleman on 2013-01-10:
I'm on 12.04. The packages are available again - not sure if it was my computer or the servers.

Comment by ben on 2013-02-04:
I updated on electric (ros-electric-openni-kinect (0.3.4-s1336532617~lucid => 0.3.6-s1356576176~lucid)) and it broke everything. I got the "No Device Connected" error, I reinstalled and it fixed it.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.