0
$\begingroup$

Rosanswers logo

Hi guys,

I am using ros fuerte and ubuntu 12.04, I am trying to use the robotino stacks and have followed the instructions from http://wiki.openrobotino.org/index.php?title=ROS, I have downloaded the api2 packages on my laptop running ubuntu 12.04. The CF card has an image of version 2.4 (I think api1). I know I need to update my CF card to api2. But I still expected the make to be successful (even if the connection to robotino will fail until I update the CF card to api2). I have added the robotino-ros-pkg to my ROS PACKAGE PATH. When I run the comand : $ rosmake --pre-clean robotino

I get the following error at the end:

Linking CXX executable ../bin/robotino_camera_node /usr/local/robotino/api2/lib/librec_robotino_api2.so: could not read symbols: File in wrong format collect2: ld returned 1 exit status make[3]: *** [../bin/robotino_camera_node] Error 1 make[3]: Leaving directory /home/samme/robotino-ros-pkg/trunk/robotino/robotino_node/build' make[2]: *** [CMakeFiles/robotino_camera_node.dir/all] Error 2 make[2]: Leaving directory /home/samme/robotino-ros-pkg/trunk/robotino/robotino_node/build' make[1]: *** [all] Error 2 make[1]: Leaving directory `/home/samme/robotino-ros-pkg/trunk/robotino/robotino_node/build'

[ rosmake ] Output from build of package robotino_node written to: [ rosmake ] /home/samme/.ros/rosmake/rosmake_output-20121231-130653/robotino_node/build_output.log [rosmake-0] Finished <<< robotino_node [FAIL] [ 7.27 seconds ]
[ rosmake ] Halting due to failure in package robotino_node. [ rosmake ] Waiting for other threads to complete. [ rosmake ] Results:
[ rosmake ] Cleaned 51 packages.
[ rosmake ] Built 47 packages with 1 failures.
[ rosmake ] Summary output to directory
[ rosmake ] /home/samme/.ros/rosmake/rosmake_output-20121231-130653

Any ideas why I am getting this error? /usr/local/robotino/api2/lib/librec_robotino_api2.so: could not read symbols: File in wrong format

Thanks and best regards,

Khalid


Originally posted by K_Yousif on ROS Answers with karma: 735 on 2012-12-30

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Ok so I realized I had installed the i386 api2 packages instead of the amd64 api2 packages. I then recieved another float conversion error problem so I added this line to the cmakelists.txt:

add_definitions (-Wall -O3 -funroll-loops -fpermissive)

and the build was successful.

regards

Khalid


Originally posted by K_Yousif with karma: 735 on 2013-01-01

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.