0
$\begingroup$

Rosanswers logo

Hi guys,

I am still having a problem with running RGBDSLAM on ubuntu 12.04 and fuerte.

I know what my problem is but I cannot resolve it. heres what I did.

I initially downloaded g2o into my workspace /home/samme/fuerte_workspace/trunk/. using the command svn co: https://svn.openslam.org/data/svn/g2o/trunk. However I was getting some errors.

I then removed this file into the rubbish bin and followed the instructions given by this link: http://answers.ros.org/question/50585/rgbdslam-error-in-fuerte-and-electric/. I re-downloaded the g2o into home (/home/samme/trunk) by running this command:

svn co https://code.ros.org/svn/ros-pkg/stacks/vslam/trunk/

However, when I rosmake, I get this error :

/home/samme/fuerte_workspace/rgbdslam_freiburg/rgbdslam/src/edge.h:22:72: fatal error: /home/samme/fuerte_workspace/trunk/g2o/math_groups/se3quat.h: No such file or directory

The problem is that there is a conflict from my previous svn download. It is still trying to access that file (/home/samme/fuerte_workspace/trunk/g2o/) although I removed it to the rubbish bin.

Any ideas of how to resolve this conflict?

Thanks and best regards,

Khalid


Originally posted by K_Yousif on ROS Answers with karma: 735 on 2012-12-18

Post score: 0


Original comments

Comment by 746666288 on 2013-11-04:
hi I am new to rgbdslam .my systerm is ubuntu11.10 64bit electric .when i type command"rosmake --rosdep-install rgbdslam" error occured:致命错误: g2o/math_groups/se3quat.h:没有那个文件或目录 it like your error.so i want to know how did you solve your problem.thanks

Comment by longzhixi123 on 2013-12-08:
hello, I encountered a similar problem with you.when i type command"rosmake --rosdep-install rgbdslam". i get the error occured:g2o/math_groups/se3quat.h No such file or directory , Can you tell me how to solve this problem? thanks a lot

Comment by K_Yousif on 2013-12-08:
It was a really long time so I do not remember the details. However I remember that there was a problem with g2o therefore I uninstalled the ROS g2o package and installing a general g2o. However I do not think this is a good solution and I am sure others have solved this problem in another way.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I realized I had previously played with the #include in some of the files. I restored it to the default settings. Now I am receiving a different error:

opt/ros/fuerte/include/g2o/core/hyper_graph.h:59:22: error: redefinition of ‘class g2o::HyperGraph’ /home/samme/trunk/g2o/include/g2o/core/hyper_graph.h:46:9: error: previous definition of ‘class g2o::HyperGraph’

It seems that there is a conflict between the g2o that I installed and the one in ros-fuerte. Does anyone know how to uninstall the g2o that is already included in ROS?

Thanks,

Khalid


Originally posted by K_Yousif with karma: 735 on 2012-12-18

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by autorover on 2012-12-22:
Try uninstalling libg2o, if you have it installed, from the ubuntu software center. Remember to use rosmake --pre-clean rgbdslam so that you don't have files from the previous make interfering.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.