0
$\begingroup$

Rosanswers logo

Hey everyone, month long lurker first time poster here. I'm running ubuntu 10.04 ROS electric turtlebot on the lenovo x130e laptop.

I've been working on the complete turtlebot kit for awhile now and I've come across an problem that just simply cannot solve. I'll do my best to explain it, so here it goes.

For quite some time I've had an issue with the follower demo as well as the mapping demo. I believe I can relate the problem between the two as well. Basically whenever I run the follower demo everything loads up but then the turtle bot follows me (generally just a straight line, Similarly when ever I begin mapping with the mapping demo everything loads up correctly and I can visually see on rviz what the robot is seeing but when I begin to move. The robot stops scanning the environment and on the rviz screen just becomes a robot moving around without detecting/scanning anything.

This was very confusing until I realised that when I ran this code I could personally see the kinect's red laser shining. However I found that after the robot sees me in the follower demo the red laser turns off, I observed the laser turning of during the mapping demo as well after beginning tele-operation or even if the robot is left stationary.

I would like to point out that the follower demo reports no errors when the robot stops moving, and the mapping demo as far as I know doesn't signal any warning to the scanner/laser not working.

Also if I simply run the kinect visualizer demo the kinect red laser stays on for the entire demo and I can have full control over that demo.

Please let me know of any information that I could that could help.

Thanks everyone,

-Cody


Originally posted by Shleaky on ROS Answers with karma: 11 on 2012-12-10

Post score: 1


Original comments

Comment by Shleaky on 2012-12-10:
Hey tfoote I just had ago at your idea, I think ive had a look at the wheels, front bumper, all usb ports and serial connections especially wires connecting to the kinect. Is there anything else I could be missing?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

This sounds like a hardware issue, with the power being lost when the robot starts moving. I suggest that you check all your cables and the power board are securely plugged in. And with the kinect powered on poke and prod at all the connectors to find if one of them or a cable is flaky.


Originally posted by tfoote with karma: 58457 on 2012-12-10

This answer was ACCEPTED on the original site

Post score: 2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.