0
$\begingroup$

Rosanswers logo

hi, I used a source code from

pcl/range_image & visualization

in my ROS package(pcl_tutorial) to create a range image. But when i make the package, i get an error

In file included from /opt/ros/fuerte/include/pcl-1.5/pcl/visualization/range_image_visualizer.h:44:0,

from /home/karthik/Desktop/OpenCV/sandbox/pcl_tutorial/src/pcd2range_image.cpp:13: /opt/ros/fuerte/include/pcl-1.5/pcl/visualization/image_viewer.h:41:28:

fatal error: vtkImageViewer.h: No such file or directory compilation terminated.

screenshot screenshot contd1 sc contd2 sc contd 3

I have highlighted the lines which i think has the error. Please help me out with this error.

I would like to make you know that :- as in the highlighted lines /opt/ros/fuerte/pcl-1.5/pcl/visualization/image_viewer.h ,i checked out the directory, which is named pcl-1.5. But i installed pcl from

pcl/Downloads

(prebuilt binaries) which happens to be pcl-1.6(as seen in ubuntu software center)

And the error vtkImageViewer.h , from my synaptics package manager, i found vtk has dependencies of pcl 1.6 which are installed and pcl 1.5 which are not installed.

Should i uninstall all pcl-1.6 packages and install pcl-1.5 because my ROS uses pcl-1.5(as i assume from the above) or should i reinstall vtk5.8.0-5(as seen from synaptic package manager) is there any other way?? please help me out.


Originally posted by KARTHIK MURUGAN on ROS Answers with karma: 48 on 2012-12-08

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

hi, I solved the error from answers.ros.org .Now I am able to build the package without any error.


Originally posted by KARTHIK MURUGAN with karma: 48 on 2012-12-09

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by OzzieTheHead on 2017-05-06:
Putting the solution itself or the summary of it would be better.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.