0
$\begingroup$

Rosanswers logo

Hello

I am trying to make the extrinsic_calibration demo work

It is on the ethzasl_mapping stack.

I have followed the instructions at http://www.ros.org/wiki/extrinsic_calibration

and cannot compile all modules in the stack.

There seems to be a git repository problem with the pointcloudmatcher

Can anyone help?

Thanks

Miguel

Here is the output of the git command

mike@atlascar1b:~/workingcopies$ git clone --recursive git://github.com/ethz-asl/ros-mapping.git ethzasl_mapping Cloning into ethzasl_mapping... remote: Counting objects: 1371, done. remote: Compressing objects: 100% (464/464), done. remote: Total 1371 (delta 912), reused 1323 (delta 866) Receiving objects: 100% (1371/1371), 228.23 KiB | 165 KiB/s, done. Resolving deltas: 100% (912/912), done. Submodule 'libnabo/upstream_src' (git://github.com/ethz-asl/libnabo.git) registered for path 'libnabo/upstream_src' Submodule 'libpointmatcher/upstream_src' (git://github.com/ethz-asl/libpointmatcher.git) registered for path 'libpointmatcher/upstream_src' Cloning into libnabo/upstream_src... remote: Counting objects: 1074, done. remote: Compressing objects: 100% (907/907), done. remote: Total 1074 (delta 711), reused 305 (delta 142) Receiving objects: 100% (1074/1074), 1.17 MiB | 317 KiB/s, done. Resolving deltas: 100% (711/711), done. Submodule path 'libnabo/upstream_src': checked out 'ee7d9046387a30cb7abbe5783b3ed115fa2dbb25' Cloning into libpointmatcher/upstream_src... remote: Counting objects: 2339, done. remote: Compressing objects: 100% (515/515), done. remote: Total 2339 (delta 1787), reused 2339 (delta 1787) Receiving objects: 100% (2339/2339), 2.80 MiB | 440 KiB/s, done. Resolving deltas: 100% (1787/1787), done. fatal: reference is not a tree: a7fea1a48f9ed8b3b237144f5a581c44d3ac9799 Unable to checkout 'a7fea1a48f9ed8b3b237144f5a581c44d3ac9799' in submodule path 'libpointmatcher/upstream_src'


Originally posted by Miguel Riem de Oliveira on ROS Answers with karma: 254 on 2012-12-04

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hi

Apparently there was a bug with the git repository.

This is solved now.

Thanks

Miguel


Originally posted by Miguel Riem de Oliveira with karma: 254 on 2012-12-04

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.