0
$\begingroup$

Rosanswers logo

I have edited the question basing on the first answer.

Ubuntu 12.04 and Fuerte

  1. Followed the wiki and resolved all the dependencies for rgbdslam_freiburg
  2. rosdep install rgbdslam_freiburg

Then

nutan@nutan-HP-EliteBook-8460w:~/fuerte_workspace$ rosmake rgbdslam

The error goes this way........

mkdir -p bin cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=rospack find rosbuild/rostoolchain.cmake .. [rosbuild] Building package rgbdslam [rosbuild] Including /opt/ros/fuerte/share/roscpp/rosbuild/roscpp.cmake [rosbuild] Including /opt/ros/fuerte/share/roslisp/rosbuild/roslisp.cmake [rosbuild] Including /opt/ros/fuerte/share/rospy/rosbuild/rospy.cmake CMake Error at CMakeLists.txt:57 (find_package): Could not find module Findg2o.cmake or a configuration file for package g2o.

Adjust CMAKE_MODULE_PATH to find Findg2o.cmake or set g2o_DIR to the directory containing a CMake configuration file for g2o. The file will have one of the following names:

g2oConfig.cmake
g2o-config.cmake

Please let me know what should be done..


Originally posted by sai on ROS Answers with karma: 1935 on 2012-11-20

Post score: 1


Original comments

Comment by sai on 2012-11-20:
Please let me know how to solve this issue and get this rgbdslam package into life

Comment by tianb03 on 2012-12-19:
Haha. I think I know the guy who is the owner of the laptop... How is your progress? R u in NTU or I2R currently?

Comment by sai on 2012-12-21:
Hi tian, Sorry for late reply, I am good, whats your email id? what do you work on?

Comment by tianb03 on 2012-12-23:
i2r id is btian, we are working on the neural cognitive robot. Recently we are going to play with the rgbdslam and want to apply some new algo to it. Just finishing installation of rgbdslam

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

TO solve the above problem and also to get the RGBDSLAM package to work.. Follow this link below.

http://answers.ros.org/question/46669/rgbdslam-on-electric-compiling-error/

Then go through the first and the third answers and it will work..coz it worked for me..


Originally posted by sai with karma: 1935 on 2012-11-21

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$
0
$\begingroup$

Rosanswers logo

Like you I ran into issues getting rgbdslam running. My setup: Ubuntu 12.04 LTS, x64, ROS Fuerte (installed from packages), rgbdslam from svn (revision 3652). Here's how I got rgbdslam build and running.

The problem I ran into when running rosmake -V rgbdslam_freiburg (-V for verbose output) was that it gave the error: “Could not find module Findg2o.cmake or a configuration file for package g2o”. This is despite running rosdep update && rosdep install rgbdslam_freiburg which installs the ros-fuerte-libg2o dependency package. From what I can see, the latest g2o package is different and puts files in different places.

The solution was to use an older g2o package. If you're also on 64 bit Ubuntu 12.04, you could grab this package from my webserver by running wget robotang.co.nz/assets/Uploads/ros/ros-fuerte-libg2o_0.0.26_amd64.zip. Unzip it and install it by going sudo dpkg -i ros-fuerte-libg2o*. Now re-run rosmake and hopefully it will build now!

I ran into another problem when it was linking: “error: undefined reference to 'clock_gettime'". Edit rgbdslam/CMakeLists.txt, and appropriately add “-lrt” in target_link_libraries. After these steps, rgbdslam is working for me.

RT


Originally posted by robotang with karma: 21 on 2012-11-30

This answer was NOT ACCEPTED on the original site

Post score: 2


Original comments

Comment by Felix Endres on 2012-12-05:
weird. I wonder why for everyone a different library seems to missing. I added it (in the hope that it's not only because of your username ;-)) in the repository.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.