0
$\begingroup$

Rosanswers logo

I am trying to run the tutorial "joy/Tutorials/Writing/TeleopNode. I am running Ubuntu 11.10 with fuerte. I am trying to use a Logtech Rumble Pad joystick. Here is a copy of my launch file:

<launch>

 <!-- Turtlesim Node-->
  <node pkg="turtlesim" type="turtlesim_node" name="sim"/>


 <!-- joy node -->
  <node respawn="true" pkg="joy"
        type="joy" name="turtle_joy" >
   <param name="dev" type="string" value="/dev/input/js1" />
   <param name="deadzone" value="0.12" />
 </node>

<!-- Axes -->
 <param name="axis_linear" value="1" type="int"/>
 <param name="axis_angular" value="0" type="int"/>
 <param name="scale_linear" value="2" type="double"/>
 <param name="scale_angular" value="2" type="double"/>

 <node pkg="turtle_teleop" type="turtle_teleop_joy" name="teleop"/>

I am getting an error:

ERROR: cannot launch node of type [turtle_teleop/turtle_teleop_joy]: turtle_teleop
ROS path [0]=/opt/ros/fuerte/share/ros
ROS path [1]=/home/brent/ros_workspace
ROS path [2]=/home/brent/ros
ROS path [3]=/opt/ros/fuerte/share
ROS path [4]=/opt/ros/fuerte/stacks

Turtlesim does come up, but I am not getting any movement with my joystick. I do get a reading from echo joy.

Any help would be appreciated,

Morpheus


Originally posted by Morpheus on ROS Answers with karma: 111 on 2012-11-17

Post score: 1


Original comments

Comment by Morpheus on 2012-11-17:
Here is my launch file: 1 2 3 4 5 6 7 8 <node respawn="true" pkg="joy" 9 type="joy" name="turtle_joy" > 10 <param name="dev" type="string" value

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

Please edit your question and provide the complete launch file, correctly formatted (mark the code and press Ctrl-k). Did you maybe copy-paste the line numbers?


Originally posted by Lorenz with karma: 22731 on 2012-11-18

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by Morpheus on 2012-11-19:
Deleting line numbers. I am getting, ERROR: cannot launch node of type [turtle_teleop/turtle_teleop_joy]: turtle_teleop ROS path [0]=/opt/ros/fuerte/share/ros ROS path [1]=/home/brent/ros_workspace ROS path [2]=/home/brent/ros ROS path [3]=/opt/ros/fuerte/share ROS path [4]=/opt/ros/fuerte/stacks

Comment by Lorenz on 2012-11-19:
As I said before, please edit your question. Reading error messages or code in comments is really hard. As your error clearly says, you are missing the node you are trying to launch. Did you install it?

Comment by Morpheus on 2012-11-22:
I hope that I have edited my question a little better.

$\endgroup$
0
$\begingroup$

Rosanswers logo

Looking more carefully at the tutorial I noticed last line after the launch file, "Since we built everything in package learning_joy, you may need to change the package in the last line from turtle_teleop to learning_joy." I made the change to my launch file, and everything works fine.

Thanks for your help, Morpheus


Originally posted by Morpheus with karma: 111 on 2012-11-25

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.