0
$\begingroup$

Rosanswers logo

Hi, I'm not familiar at ROS errors,, firstly , i installed Roboearth Stack using these four steps :

http://www.ros.org/wiki/roboearth

the result of that : I have the roboearth stack in Home/ros

i made a connection between this and ROS by opening bashrc file and typed "export ROS_PACKAGE_PATH=/opt/ros/fuerte/share:/opt/ros/fuerte/stacks:/home/ros"

and saved

i begin to run re_comm package in roboearth stack but itthrow an error

salma@salma-G31M-S2L:~$ rosrun re_comm run
[rospack] Error: stack/package re_comm not found

i don't know why ??? re_comm not in /opt/ros/fuerte/stacks but in /home/ros/roboearth

why not found ??

and this is the result of rosmake roboearth now

salma@salma-G31M-S2L:~$ rosmake roboearth
[ rosmake ] rosmake starting...                                                 
[ rosmake ] Packages requested are: ['roboearth']                               
[ rosmake ] Logging to directory /home/salma/.ros/rosmake/rosmake_output-20121111-201259
[ rosmake ] Expanded args ['roboearth'] to:
[]                                  
[ rosmake ] WARNING: The following args could not be parsed as stacks or packages: ['roboearth']
[ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.

Originally posted by salma on ROS Answers with karma: 464 on 2012-11-11

Post score: 3


Original comments

Comment by salma on 2012-11-12:
@tbh ???? any help here ?

Comment by salma on 2012-11-12:
@Lorenz ???? any help here ?

Comment by Lorenz on 2012-11-12:
Please do not add my name just to enforce a notification email. I see your question and I will answer it if I know the answer and if I have time. Be aware that I'm giving support here in my free time and voluntarily.

Comment by thebyohazard on 2012-11-12:
Are you sure /home/ros is the correct directory for roboearth? In FHS (Filesystem Hierarchy Standard), the home directory ~/. is the same as /home/username/. /home/. is a different place. Since your username is salma, I'd guess that you should use /home/salma/ros instead of /home/ros

Comment by salma on 2012-11-12:
lorenz @

i didn't mean it :S ,, just i was reading ROS EnvironmentVariables and it was last updates by u !! so i mentioned u ,,,,, Not to enforce a notification email !! ,, thanks by the way :)

Comment by salma on 2012-11-12:
@tbh Ok I will try it and tell you the result ,, yesterday i decided to uninstall ROS and install it again after no one answered me ,, i 'm installing it again and 'll retry :) thanks very much

Comment by salma on 2012-11-13:
@tbh
it's okey it solved ,, thanks very much

Comment by thebyohazard on 2012-11-13:
Great! Be sure and post the answer or accept the right one for others who might have the same problem.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

the home directory ~/. is the same as /home/username/.
you should use /home/username/ros instead of /home/ros


Originally posted by salma with karma: 464 on 2012-11-13

This answer was ACCEPTED on the original site

Post score: 2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.