0
$\begingroup$

Rosanswers logo

I finally got my hands on a Roomba Model 533, best I can do right now. I have been experimenting with electric and so far I have been able to partially get the roomba_500_series to work, intermittent kinect and camera, mostly because I have only found 'partial tutorials'.

I have also been able to teleop from keyboard using the tutorials but it keeps moving and won't stop. I had to modify the roomba_teleop_key python executable to make it stop.

My question is: Is it possible to get the 533 Roomba to work with TurtleBot ROS Fuerte RC1 iso or is it just for those lucky enough to have the fundage to purchase the Create??

Anyone have any experience along these lines that would have to patience to assist?

Ok I have fuerte installed to the hard drive and the minimal.launch file is :

port: /dev/ttyUSB0 publish_tf: True robot:type: roomba has_gyro: False

I am now getting the following error in rxconsole - Failed to contact device with error: [Error reading from SCI port. No data.]. Please check that the Create is powered on and that the connector is plugged into the Create

I purchased the cable from irobot and the roomba is turned on...


I also checked the following

turtlebot@turtlebot-Presario-CQ56-Notebook-PC:/dev$ ls /dev/ttyUSB* /dev/ttyUSB0

turtlebot@turtlebot-Presario-CQ56-Notebook-PC:/dev$ dmesg | grep ttyUSB [ 57.669696] usb 5-1: FTDI USB Serial Device converter now attached to ttyUSB0


Originally posted by JP Schubert on ROS Answers with karma: 16 on 2012-11-01

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

SOLVED!! I was copying the minimal.launch example file the you suggested above and after 3 reimages I was able to fine another webpage where someone else had same issue and one person in the forum stated - you have a typo in statement robot:type: roomba It should be robot_type: roomba !!!

a single underscore was the reason for the non-communication with SCI port!!!

show link - http://answers.ros.org/question/47094/turtlebot-roomba-dashboard/?answer=47096#post-id-47096

example in middle of page of minimal.launch should be robot_type: roomba

Thanks Lorenz for you help!!


Originally posted by JP Schubert with karma: 16 on 2012-11-03

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.