0
$\begingroup$

Rosanswers logo

hey, i got some problems with getting my turtlebot started.

  1. have and ubuntu 11.10 running with ros on asus eeepc.
  2. started with the turotials at ROS Turtlebot Tutorial
  3. at the tutorial turtlebot_bringup i got the error Failed to open port /dev/ttyUSB0

to be a bit mor clear i tried rostopic echo /diagnostics whitch presents me this message as well as the Dashoard as well as if i type roslaunch turtlebot-bringup minimal.launch

4.i tried to solf this problem using with this possible solutions

  1. ROSANSWERS
  2. ROSANSWERS
  3. ROSANSWERS
  4. ROSANSWERS
  5. ROSANSWERS
  6. ROSANSWERs

but nothing changed

again more clear i changed the chmod of /dev/ttyUSB0, i tried udev rules, i have tested if there is an connection to this port with lsusb and dmesg | grep usb as well ass cd /dev/serial/by_id/ ls -al.

All confirm me my serial device converter (needed for the connection from pc to rommba cleaner) is attached to ttyUSB0

My anybody got some advices for me?

edit:

lsusb

Bus 004 Device 003: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC

dmesg|grep usb

[  130.917744] usb 4-1: FTDI USB Serial Device converter now attached to ttyUSB0

cd /dev/serial/by_id/``ls -al

lrwxrwxrwx 1 root root 13 2012-10-29 15:07 usb-FTDI_FT232R_USB_UART_A900Y9QC-if00-port0 -> ../../ttyUSB0

rostopic echo /diagnostics

    der:
  seq: 4
  stamp: 
    secs: 1351520860
    nsecs: 565383911
  frame_id: ''
status: 
  - 
    level: 2
    name: TurtleBot Node
    message: Failed to open port /dev/ttyUSB0.  Please make sure the Create cable is plugged into the computer. 

    hardware_id: ''
    values: []
---

roslaunch turtlebot_bringup minimal.launch

turtlebot@turtlebot-R002:~$ roslaunch turtlebot_bringup minimal.launch ... logging to /home/turtlebot/.ros/log/bf90e012-21d5-11e2-98d7-0008ca665690/roslaunch-turtlebot-R002-8292.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is

Originally posted by paetti88 on ROS Answers with karma: 25 on 2012-10-25

Post score: 2


Original comments

Comment by dornhege on 2012-10-25:
First, post the output of the commands. Second, try opening the port in gtkterm or similar (or even cat first) to see if it can be opened in principle and send some chars.

Comment by paetti88 on 2012-10-25:
i am dont know how i format the terminal output properly .. how do i do this?

Comment by dornhege on 2012-10-26:
gtkterm or here? Here, you can use tags or for code indent by 4 spaces.

Comment by PerkinsJames on 2012-10-26:
I assume gtkterm is similar to minicom, but I always try minicom first.

Comment by dornhege on 2012-10-29:
To me it looks like everything is OK. Can you try just opening it using gtkterm or similar to see if you can open the port with the same parameters. If that works the only explanation I have is that the error msg might be misleading, i.e. the port could be opened, but commnucation fails (bad cable, protocol, etc.)

Comment by dornhege on 2012-10-29:
According to the error msg you added, there is a comm error. So, I would check at the other end, i.e. is there only one USB device (i.e. might it just try to connect to something else), is cables, hardware, etc. OK.

Comment by paetti88 on 2012-10-29:
im not sure how i have to use gtkterm to open it how i do this? ... no there are no other usb devices connectet.

Comment by paetti88 on 2012-10-29:
at this problem http://answers.ros.org/question/11400/error-opening-turtlebot_dashboard/ they say they "recommend to check roomba stack" .. what does this mean?

Comment by dornhege on 2012-10-29:
The default turtlebot base is an irobot create. Roomba is the vacuum variant used in European turtlebot models. The roomba stack is probably this one: http://www.ros.org/wiki/roomba_500_series

Comment by Lorenz on 2012-10-29:
Are you using a roomba or an iCreate? In case of a roomba, I would not suggest to use the roomba stack but still the turtlebot driver. You''ll have to use a different robot launch file. See here

Comment by paetti88 on 2012-10-29:
jea i got an roomba and i tryed to use an other launch file but this doesent work ..

Comment by phil0stine on 2012-10-29:
What happens if you force chmod the permissions to /dev/ttyUSB0 , then launch? Did you use SYSFS or ATTRS in your udev rules?

Comment by paetti88 on 2012-10-30:
used ATTRS ... i did force permissons

Comment by Sentinal_Bias on 2013-05-29:
Hi i got messages returned via minicom from the create, however when i try the launchfile it doesn'twork...

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

Did you reload udev rules after adding new ones? Are you sure rules were propertly added? There is still something wrong with permissions.

Post output of ls -la /dev/ttyUSB* and groups

First you need to be in dialout group, then make sure tty is owned by this group.

To add yourself to group:

gpasswd -a yourUserName dialout

Then relog / restart X server / reboot to make sure

udev rule:

ATTRS{idProduct}=="6001",ATTRS{idVendor}=="0403",MODE="666",GROUP="dialout"

Originally posted by kszonek with karma: 459 on 2012-10-29

This answer was ACCEPTED on the original site

Post score: 3


Original comments

Comment by Sentinal_Bias on 2013-05-29:
crw-rw---- 1 root dialout 188, 0 May 30 17:05 /dev/ttyUSB0

$\endgroup$
0
$\begingroup$

Rosanswers logo

You could check the permissions of ttyUSB0

ls -la /dev/

If the perms are not 666 or a+rw then you need to boot with usb that has permission to access. Basically you need to create a new rule in /etc/udev/rules.d:

Create a new file with your specific permissions (higher numbers override existing rules):

cd /etc/udev/rules.d/
touch 80-turtlebot.rules
sudo pico 80-turtlebot.rules

Add the following lines for every usb device:

#serial usb
SUBSYSTEM=="usb", ATTRS{idProduct}=="6001", ATTRS{idVendor}=="0403", MODE="0666", GROUP="turtlebot"

To find the product id and vendor id, do lsusb -v, I think if you just do regular lsusb its vendor:product. Shift + PgUp to view previous parts of the cli.

finally reboot

sudo reboot

Originally posted by newe1344 with karma: 21 on 2013-07-10

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.