0
$\begingroup$

Rosanswers logo

Hello,

I am trying to install asctec drivers on workstation, both asctec_drivers and mav_tools folders (package) are in workspace. After command ‘rosmake mav_tools’,I get following errors:


[ rosmake ] Packages requested are: ['mav_tools']
[ rosmake ] Logging to directory/home/roboticslab/.ros/rosmake/rosmake_output-20121022-094533
[ rosmake ] Expanded args ['mav_tools'] to: ['mav_common', 'city_flyer_launch', 'mav_srvs', 'quad_joy_teleop', 'ab_filter', 'mav_odom_interface', 'flyer_interface', 'laser_height_estimation', 'mav_msgs', 'mav_ctrl_interface']

[ rosmake ] Checking rosdeps compliance for packages mav_tools. This may take a few seconds.

Failed to find stack for package [navfn] Failed to load rosdep.yaml for package [navfn]:Cannot locate installation of package navfn: [rospack] opendir error [No such file or directory] while crawling /home/roboticslab/Pelican_workspace/astec_drivers [rospack] couldn't find package [navfn]. ROS_ROOT[/opt/ros/electric/ros] ROS_PACKAGE_PATH[/home/roboticslab/Pelican_workspace:/opt/ros/electric/stacks:/home/roboticslab/Pelican_workspace/astec_drivers:/home/roboticslab/Pelican_workspace/mav_tools]

Failed to find stack for package [costmap_2d] Failed to load rosdep.yaml for package [costmap_2d]:Cannot locate installation of package costmap_2d: [rospack] opendir error [No such file or directory] while crawling /home/roboticslab/Pelican_workspace/astec_drivers [rospack] couldn't find package [costmap_2d]. ROS_ROOT[/opt/ros/electric/ros] ROS_PACKAGE_PATH[/home/roboticslab/Pelican_workspace:/opt/ros/electric/stacks:/home/roboticslab/Pelican_workspace/astec_drivers:/home/roboticslab/Pelican_workspace/mav_tools] [ rosmake ] rosdep check passed all system dependencies in packages
[rosmake-0] Starting >>> mav_ctrl_interface [ make ]
[ rosmake ] All 23 linesav_ctrl_interface: 0.1 sec ] [ 1 Active 1/53 Complete ] {------------------------------------------------------------------------------- mkdir -p bin cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=rospack find rosbuild/rostoolchain.cmake .. [rosmake-1] Starting >>> rosbuild [ make ]
[rosbuild] Building package mav_ctrl_interface Failed to invoke /opt/ros/electric/ros/bin/rospack deps-manifests mav_ctrl_interface [rosmake-1] Finished <<< rosbuild ROS_NOBUILD in package rosbuild No Makefile in package rosbuild
[rospack] opendir error [No such file or directory] while crawling /home/roboticslab/Pelican_workspace/astec_drivers [rospack] couldn't find dependency [navfn] of [mav_ctrl_interface] [rospack] missing dependency

CMake Error at /opt/ros/electric/ros/core/rosbuild/public.cmake:129 (message):

Failed to invoke rospack to get compile flags for package
'mav_ctrl_interface'.  Look above for errors from rospack itself.
Aborting.  Please fix the broken dependency!

Call Stack (most recent call first): /opt/ros/electric/ros/core/rosbuild/public.cmake:206 (rosbuild_invoke_rospack) CMakeLists.txt:12 (rosbuild_init)

-- Configuring incomplete, errors occurred!

[ rosmake ] Output from build of package mav_ctrl_interface written to: [ rosmake ] /home/roboticslab/.ros/rosmake/rosmake_output-20121022-094533/mav_ctrl_interface/build_output.log [rosmake-0] Finished <<< mav_ctrl_interface [FAIL] [ 0.17 seconds ]
[rosmake-2] Starting >>> cpp_common [ make ]
[rosmake-2] Finished <<< cpp_common ROS_NOBUILD in package cpp_common
[rosmake-3] Starting >>> roslib [ make ]
[ rosmake ] Halting due to failure in package mav_ctrl_interface. [ rosmake ] Waiting for other threads to complete. [rosmake-2] Starting >>> roslang [ make ]
[rosmake-2] Finished <<< roslang ROS_NOBUILD in package roslang No Makefile in package roslang
[rosmake-3] Finished <<< roslib ROS_NOBUILD in package roslib
[ rosmake ] Results:
[ rosmake ] Built 6 packages with 1 failures.
[ rosmake ] Summary output to directory
[ rosmake ] /home/roboticslab/.ros/rosmake/rosmake_output-20121022-094533


I am following the steps mentioned on:

http://www.ros.org/wiki/asctec_drivers

http://www.ros.org/wiki/mav_tools

If some one could please suggest any solution, it will be really helpful. Thank you.


Originally posted by dbs on ROS Answers with karma: 1 on 2012-10-21

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I don't know if you already had it done, but for those who may get stucked in such a problem, here is my step by step to install mav_tools and asctec_drivers . It worked to me, for ROS-Groovy, after a lot of mistakes and helps from this forum. I will start from the beginning:

First step, make sure you have GIT installed:

sudo apt-get install git-core

Second step, create a folder where you are going to have other packages from ROS, those you can not install through apt-get... For example:

mkdir ~/rospackages
cd ~/rospackages
and download the packages, you can find the links in Ros website. I cant publish links here.

Third step, you need to indicate where are the ROS packages, now you will have two folders, the original from ROS installation, and the one you have created:

export ROS_PACKAGE_PATH=~/rospackages/:/opt/ros/groovy

The : adds another folder, so if you have another folder to add, just write : and the location. It is important that ~/rospackages comes first so, you won't have any problems with read/write problems.

Fourth step, now you can do:

rosdep install mav_tools
rosmake mav_tools

Well, I had two erros after doing rosmake, so it leads to my final steps. If there were no errors after rosmake, ignore the following steps:

Fifth step, you may have an error related to the version of rosdep, it is caused due a conflict with the versions installed. So you will need to remove the easy-installed version:

sudo rm -rf /usr/local/lib/python2.7/dist-packages/rosdep*

Try again rosmake mav_tools.

Sixth step, you may have a problem related to rosgraph and python-netifaces. Just do the following command:

rosdep update

Try again rosmake mav_tools

After you have done it, just write:

rosdep install asctec_drivers
rosmake asctec_drivers

Originally posted by Amarante with karma: 31 on 2013-04-16

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by Sendoh on 2013-08-19:
Dear Amarante ,

By using "sudo rm -rf /usr/local/lib/python2.7/dist-packages/rosdep*" , I can not remove the easy-installed version. My rosdep version is 0.9.7. Can you give me further help?

Comment by lucasbpro on 2014-06-30:
I am having the same problem! Can someone help me out?

Comment by aly on 2014-10-16:
Hi! I am getting the following error on running first command of 4th step and unable to resolve it:

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: laser_height_estimation: Missing resource bullet ROS path [0]=/opt/ros/groovy/share/ros ROS path

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.