0
$\begingroup$

Rosanswers logo

Hi,

I just got started with ROS, and I bumped into the first wall when I was going through the tutorial in running turtlesim.

After I ran 'roscore', 'rosrun turtlesim turtlesim_node' and 'rosrun turtlesim turtle_teleop_key', it went through the settings fine. However, it is not responding to my keyboard control. I selected the terminal window of the turtle_teleop_key, but no luck.

While running them, I ran rxgraph to see the diagram, but it mentioned that the node communication failed, so I am predicting it's the problem with network setting, but I don't know how to fix it.

I would greatly appreciate for your help.

Thank you.


Originally posted by daikii on ROS Answers with karma: 11 on 2012-10-17

Post score: 0


Original comments

Comment by Harsh2308 on 2017-09-01:
Are you able to move it via manually publishing to the turtlesim_node?

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

It's hard to help without further information. As a first step, have a look at the network setup page. rosnode info teleop_turtle might also provide some information.


Originally posted by Lorenz with karma: 22731 on 2012-10-17

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$
0
$\begingroup$

Rosanswers logo

current program

  • put your mouse cursor on the terminal (which make it the current program to accept keys), and try to move your turtle again.
  • The problem may because you put your turtlesim at the most front, but turtlesim is not the true one to accept keys.

Originally posted by wangzheqie with karma: 11 on 2017-10-03

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.