0
$\begingroup$

Rosanswers logo

hi. I want to run RGBDSLAM, but encountered a problem.link text I've been using the svn to taken out rgbdslam and g2o when I want to compile:rosmake --rosdep-install rgbdslam
i got the info:

Eigen package was not found. This is OK FOR ROS ELECTRIC, bad for fuerte
  
  [rosbuild] Couldn't find source file /home/lg/ros/rgbdslam/build/src/moc_qtros.cxx; assuming that it is in /home/lg/ros/rgbdslam and will be generated later
  [rosbuild] Couldn't find source file /home/lg/ros/rgbdslam/build/src/moc_openni_listener.cxx; assuming that it is in /home/lg/ros/rgbdslam and will be generated later
  [rosbuild] Couldn't find source file /home/lg/ros/rgbdslam/build/src/moc_qt_gui.cxx; assuming that it is in /home/lg/ros/rgbdslam and will be generated later
  [rosbuild] Couldn't find source file /home/lg/ros/rgbdslam/build/src/moc_graph_manager.cxx; assuming that it is in /home/lg/ros/rgbdslam and will be generated later
  [rosbuild] Couldn't find source file /home/lg/ros/rgbdslam/build/src/moc_glviewer.cxx; assuming that it is in /home/lg/ros/rgbdslam and will be generated later
  [rosbuild] Couldn't find source file /home/lg/ros/rgbdslam/build/src/moc_ros_service_ui.cxx; assuming that it is in /home/lg/ros/rgbdslam and will be generated later
  -- Configuring incomplete, errors occurred!
-------------------------------------------------------------------------------}
[ rosmake ] Output from build of package rgbdslam written to:
[ rosmake ]    /home/lg/.ros/rosmake/rosmake_output-20121017-111712/rgbdslam/build_output.log
[rosmake-3] Finished <<< rgbdslam [FAIL] [ 10.02 seconds ]                      
[ rosmake ] Halting due to failure in package rgbdslam. 
[ rosmake ] Waiting for other threads to complete.
[ rosmake ] Results:                                                            
[ rosmake ] Built 53 packages with 1 failures.                                  
[ rosmake ] Summary output to directory                                         
[ rosmake ] /home/lg/.ros/rosmake/rosmake_output-20121017-111712   

and i have edit my manifest.xml.as link text my pc: ubuntu 11.10 64 bit. ROS ELECTRIC. Very much hope to your help.Thank you。


Originally posted by longzhixi123 on ROS Answers with karma: 78 on 2012-10-16

Post score: 1


Original comments

Comment by longzhixi123 on 2012-10-18:
Is there no one to run successfully RGBDSLAM?

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

I am in the same boat with getting errors when trying to run RGBDslam with Fuerte, but I think I solved the above error message with help from the comment by dornhege: answers.ros.org/question/46669/rgbdslam-on-electric-compiling-error/. Make sure that you have g2o downloaded correctly by running roscd g2o. If you get an error and are not transported to a new directory, try downloading with svn straight into a recognized ROS path. Then remember to edit your CMakeLists file after editing the manifest as mentioned in the previous comment by removing find_package(g2o REQUIRED).


Originally posted by autorover with karma: 93 on 2012-12-13

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$
0
$\begingroup$

Rosanswers logo

I think that the relevant error message is actually above the output you posted. All the "couldn't find source..." messages are fine and unavoidable on first compilation, since qt needs to create meta classes. The actual error is "Configuring incomplete". This is normally due to a missing dependency, either a library or a ros package. I can't see which one because the output is missing. Can you post the whole output of rosmake rgbdslam please.


Originally posted by Felix Endres with karma: 6468 on 2012-10-24

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.