0
$\begingroup$

Rosanswers logo

I'm testing kinect reading using openni_launch following instructions link: openni_launch tutorial

and when I came to the dynamic_reconfigure gui part. My kinect cannot be read anymore. I doubt that it did something to the original driver parameters

I tried to restart my PC and run the tutorial again (without dynamic_reconfigure) then it worked. Then how can I register the points??

What is the problem here?

Edit 01:

I changed Topic to registered depth points (without using dynamic reconfigure) or close RVIZ. All led to the same pending and unable to load kinect again

it only works again when I restart the PC

Edit 02:

I tried with rostopic echo /rosout to see the stream of data. But type of /rosout is rosgraph_msgs/Log and cannot be seen clearly i.e. matrix of number. I don't know how to see the image data yet


Originally posted by roskidos on ROS Answers with karma: 110 on 2012-10-14

Post score: 0


Original comments

Comment by yigit on 2012-10-15:
So once you enable depth-registration openni stops publishing, do I understand correctly? Did you confirm this by echoing the topics (rostopic echo /camera/...)? If so, what happens when you disable depth-registration again? Does it continue to publish points or just freeze?

Comment by roskidos on 2012-10-15:
actually, I've just tried other things e.g. change Topic to registered depth points (without using dynamic reconfigure) or close RVIZ. They all led to the same pending and unable to load kinect again. I'm trying to show data using rostopic ... like you said. But whenever I restart the PC, it works

Comment by joq on 2012-10-15:
/rosout is not the image. It is a collection of ROS log messages. You can view them with rxconsole

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

This may be a bug in the driver. If some combination of parameters doesn't work on the device, it may hang with the driver unable to recover cleanly. If so, you should open a Trac defect ticket.

Does restarting only the driver get things working again? (Please edit your question to provide more information about that.)

EDIT: hard to tell much from your description. Either your device is not working or the driver is not contacting it correctly.


Originally posted by joq with karma: 25443 on 2012-10-15

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by roskidos on 2012-10-15:
thank you for answering my question!! I'm working on capturing the output data. perhaps I will post the asnwer here

Comment by yigit on 2012-11-01:
@ROSbeginner we had a similar issue. joq's answer led me to the right way. Please see here http://answers.ros.org/question/46066/kinect-dynamic-reconfigure-does-not-work/?answer=46450#post-id-46450

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.