0
$\begingroup$

Rosanswers logo

I have a roomba 780 that I am trying to run turtlebot on. I have been able to install the turtlebot fuerte on the both pc and I can ssh into the turtlebot computer, so all communication parts are set and are working. But when I start the turtlebot nothing happens , I can start the turtlebot service so it run but i cant comunicate with my roomba. I think i know/have read that you have to change the communication speed and also tell in the launch file that you have a roomba and that it has no gyro.

However I have no clue how to change the launch file. I have done the basic tutorials, but still not getting how I create or edit the launch file?! Some help or guidance to where on the forum i find this info would be very appreciated

Thanks


Originally posted by krst on ROS Answers with karma: 11 on 2012-10-10

Post score: 0


Original comments

Comment by krst on 2012-10-11:
Many thanks Lorenz, I am still however little confused where to put and create the launch file? Because when i tried to edit the launch file in the etc/ros folder it was write protected the folder and file. I assume I am doing this completly wrong the launch file creation?

Comment by Lorenz on 2012-10-11:
Just put the launch file somewhere and execute it with roslaunch. Make sure that no other turtlebot related stuff is running to avoid conflicts.

Comment by krst on 2012-10-14:
I am seeing that I get the error message [Distance, angle displacement too big, invalid readings from robot. Distance: 1.84, Angle: -21.02]. I have a memory that i have seen this here before on the forum but cant find the post... When i look at the node.py this error message I thought only would come for a create?

Comment by Lorenz on 2012-10-14:
Please do not delete a complete question and replace it by a new question to not lose the connection between questions and answers. Instead, please create a new question.

Comment by krst on 2012-10-15:
Ok sorry, I saw it as an extentions of the same topic but I will edit back and do that instead! Thanks!

Comment by Lorenz on 2012-10-15:
I think it's just important to keep the old question. If you want, you can of course edit it and add further information. But in case you have a separate, although maybe related question, I guess it's better to open a new question. That's what this site is all about in the end :)

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I am not sure how different the communication protocols between the roomba 780 and the roomba 530 are. You could try the following launch file to bring up the robot's base driver:

<launch>
  <node name="turtlebot_node" type="turtlebot_node.py" pkg="turtlebot_node">
    <rosparam>
      port: /dev/ttyUSB0
      publish_tf: True
      robot_type: roomba
      has_gyro: False
    </rosparam>
  </node>
</launch>

Make sure that the usb port is correct. If launching the file does not throw an error, rostopic echo /odom should publish data and you should be able to teleop the robot. If you are getting errors, I guess the communication protocol changed. In that case you might have to patch the turtlebot driver. Patches welcome :)


Originally posted by Lorenz with karma: 22731 on 2012-10-10

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.