0
$\begingroup$

Rosanswers logo

I seem to have a catch 22 situation using interactive markers and point clouds in rviz. What i am trying to do is manually align multiple planar laser scans with interactive markers. (I know that there is a scan matching package, but there is very little overlap between my lasers, and i was just trying to do something quick and dirty). the laser scans have been converted to PointCloud2 types. My interactive marker node simply takes the marker position and broadcasts this pose to tf. I am using Fuerte on Ubuntu 12.04, with roscore on an external machine.

  1. my interactive markers don't seem to work unless i start rviz before launching my (python) interactive marker node.

  2. my pointclouds don't seem to display in rviz unless they are publishing before rviz starts.

  3. starting my lasers, then rviz, then the interactive markers doesn't work because rviz can't find the tf frames for the laser scans. (This restriction isn't an issue when the rosmaster is local).

Is there any workaround for this? Perhaps a way to get rviz to refresh or reload tf info when using an external master? or is there a way to publish a long lasting tf frame before my laser nodes start, then i can override this frame with the interactive markers later?


Originally posted by baxelrod on ROS Answers with karma: 794 on 2012-09-27

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

In ROS it should never matter in which order you start up your nodes. If topics do not connect, I suspect that something is fishy with the network configuration. Try setting ROS_IP on all computers involved.


Originally posted by Lorenz with karma: 22731 on 2012-09-27

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by baxelrod on 2012-09-27:
i think you are right. i can only ping in one direction.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.