0
$\begingroup$

Rosanswers logo

Hi everybody, I can run mono_odometer application properly, but I continue to get the warning showed in the title. How to fix it? How can I set the tf from /base_link' to '/camera' ?

Kind regards. Aldo


Originally posted by aldo85ita on ROS Answers with karma: 252 on 2012-09-20

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Do you know the tf library? If not, read up on that.

You need to define a transform from /base_link to /camera, i.e. basically where it is mounted on the robot. If that is fixed, you can use a static_transform_publisher, otherwise define a URDF description.


Originally posted by dornhege with karma: 31395 on 2012-09-20

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by aldo85ita on 2012-09-20:
I know how to create a tf object , but I don't know how to set it. In particularly, I don't know how to set base_link_frame_id tf of viso2ros.

Comment by dornhege on 2012-09-20:
Use a static_transform_publisher or create an urdf. You can also use a custom TransformBroadcaster if necessary.

Comment by aldo85ita on 2012-09-20:
ok, I've used roscd tf ./bin/static_transform_publisher 0 0 2 0.0 0.0 0.0 /base_link /camera 100

Comment by dornhege on 2012-09-20:
I'd advise to use rosrun. Also units are in meters, so 2 seems large (but might be correct)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.