0
$\begingroup$

Rosanswers logo

Hi guys,

I am new in ROS. I am trying to install rgbdslam on my laptop. I have got a following error: '/usr/bin/ld: cannot find -lGL' and later I have got 'SiftGPU cannot be compiled. Returned: 2'.

What should I do? help me please.

Thanks in advance


Originally posted by SHPOWER on ROS Answers with karma: 302 on 2012-09-09

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Install all this before building the package rgbdslam,

sudo apt-get install libglew1.5-dev libdevil-dev libsuitesparse-dev libgsl0-dev.

Have you built g2o package?

I think the problem is with openGL. So, try

sudo apt-get install libglu1-mesa-dev freeglut3-dev freeglut3 mesa-common-dev libqt4-opengl binutils-gold


Originally posted by Sudhan with karma: 171 on 2012-09-09

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.