0
$\begingroup$

Rosanswers logo

I just created a brand-new VM running 12.04 and am attempting to install ROS fuerte. I've followed the instructions from http://ros.org/wiki/fuerte/Installation/Ubuntu to set up sources.list and keys and done sudo apt-get update. Running sudo apt-get install ros-electric-desktop-full fails with the following error:

The following packages have unmet dependencies: ros-fuerte-desktop-full : Depends: ros-fuerte-simulator-gazebo (= 1.6.15-s1346825464~precise) but it is not going to be installed E: Unable to correct problems, you have held broken packages.

Likewise, trying to install ros-fuerte-simulator-gazebo gives:

The following packages have unmet dependencies: ros-fuerte-simulator-gazebo : Depends: ros-fuerte-bullet (= 2.79-s1346186848~precise) but it is not going to be installed Depends: ros-fuerte-common-msgs (= 1.8.13-0precise-20120813-1503-+0000) but it is not going to be installed Depends: ros-fuerte-common-rosdeps (= 1.2.0-s1346186808~precise) but it is not going to be installed Depends: ros-fuerte-driver-common (= 1.4.0-s1346186749~precise) but it is not going to be installed Depends: ros-fuerte-geometry (= 1.8.2-s1346187100~precise) but it is not going to be installed Depends: ros-fuerte-image-common (= 1.8.0-s1346187257~precise) but it is not going to be installed Depends: ros-fuerte-nodelet-core (= 1.6.5-s1346187746~precise) but it is not going to be installed Depends: ros-fuerte-perception-pcl (= 1.2.3-s1346187964~precise) but it is not going to be installed Depends: ros-fuerte-robot-model (= 1.8.1-s1346188771~precise) but it is not going to be installed Depends: ros-fuerte-ros (= 1.8.10-0precise-20120813-1418-+0000) but it is not going to be installed Depends: ros-fuerte-ros-comm (= 1.8.15-0precise-20120813-1503-+0000) but it is not going to be installed Depends: ros-fuerte-visualization-common (= 1.8.4-s1346192005~precise) but it is not going to be installed Depends: ros-fuerte-xacro (= 1.6.1-s1346189334~precise) but it is not going to be installed Depends: ros-fuerte-protobuf (= 0.1.0-s1346200515~precise) but it is not going to be installed E: Unable to correct problems, you have held broken packages.

I've seen many, many other users with similar issues here, but none of the fixes I've found so far worked for me. I've tried to install libboost1.46, suggested here but to no avail.

Can anyone help?

Thanks,

Robin


Originally posted by rdeits on ROS Answers with karma: 41 on 2012-09-07

Post score: 4


Original comments

Comment by hsu on 2012-09-07:
simulator_gazebo 1.6.16 is out, so maybe you need to do sudo apt-get update and sudo apt-get dist-upgrade first?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

This is due to a bug in the build (already fixed, packages are being rebuilt right now).

For anyone reading this, I suggest waiting a little bit for the rebuild before trying the nuclear option. :)


Originally posted by Ryan with karma: 3248 on 2012-09-08

This answer was ACCEPTED on the original site

Post score: 6


Original comments

Comment by SL Remy on 2012-09-21:
According to that ticket, this is fixed.. but I'm still seeing this problem.. I've tracked it down to "The following packages have unmet dependencies: ros-groovy-visualization-common : Depends: nvidia-cg-toolkit but it is not installable".... and no, I don't have an nvidia card.

Comment by SL Remy on 2012-10-03:
Same problem, but ended up with a different solution.. http://answers.ros.org/question/44388/has-anyone-been-able-to-install-furte-on-an-x86_64-platform/

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.