0
$\begingroup$

Rosanswers logo

Hi, I'm running the navigation stack and using rviz 2DNav to send goal to my robot but it don't avoid obstacles. I'm sure thta it detects them because they're displayed when I use the grid cells display with the obstacles and inflated obstacles topic. What could be the problem?


Originally posted by camilla on ROS Answers with karma: 255 on 2012-09-03

Post score: 0


Original comments

Comment by camilla on 2012-09-05:
I've noticed that, using 2DNav from rviz, the /goal topic published by rviz is subscribed by the proxy node and not by the move_base node, which is the one that published on /cmd_vel. Could this be an error?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

With move_base you can visualize local or global costmap.

If you are seeing the global one, it comes only from you map, not from your sensors. If you cannot see the local costmap obstacles, then your problem may be with the configurations of your yaml files. cheers


Originally posted by Procópio with karma: 4402 on 2012-09-04

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by camilla on 2012-09-04:
I can see the local costmap obstacles, to do that i'm using two grid cell display setting each topic to /move_base/local_costmap/obstacles and /move_base/local_costmap/inflated_obstacles. But also if I can see the obstacles the robot doesn't avoid them. I can't figure why.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.