0
$\begingroup$

Rosanswers logo

Hi! I tried building rosjava_core as per [1], but it always gives me the same build error. I will present the steps I took to hopefully tell you enough to be able to help me.

  1. I start out with a fresh install of Ubuntu 11.10 64-bit on vmware.
  2. I install ROS electric (ros-electric-desktop-full) following the steps from [2].
  3. I install the Android SDK (but I don't think this is of relevance for rosjava_core to build correctly).
  4. I install gradle and mercurial via apt-get (sudo apt-get install mercurial gradle).
  5. I install the Sun JDK 6u35 64-bit (because I read somewhere else that OpenJDK could turn out to be a problem if libraries are missing) and set it as my Java SDK. I also tried this step with OpenJDK as my SDK.
  6. I follow the instructions on [3] to install the rest of the other software and initialize my workspace.
  7. This is the step where it fails. When I execute "./gradlew install" [4], I get the following error message:



user@ubuntu:~/my_workspace/rosjava_core$ ./gradlew install

Building > :apache_xmlrpc_common:compileJava > Resolving dependencies ':apache:apache_xmlrpc_common:compileJava

FAILURE: Build failed with an exception.

  • What went wrong: Could not resolve all dependencies for configuration ':apache_xmlrpc_common:compile'.

Could not resolve group:org.apache.commons, module:com.springsource.org.apache.commons.httpclient, version:3.1.0. Required by: ros.rosjava_core:apache_xmlrpc_common:0.0.0-SNAPSHOT Could not GET 'http://robotbrains.hideho.org/nexus/content/groups/ros-public/org/apache/commons/com.springsource.org.apache.commons.httpclient/3.1.0/com.springsource.org.apache.commons.httpclient-3.1.0.pom'. Could not resolve group:org.apache.ws.commons, module:ws-commons-util, version:1.0.1. Required by: ros.rosjava_core:apache_xmlrpc_common:0.0.0-SNAPSHOT Could not GET 'http://robotbrains.hideho.org/nexus/content/groups/ros-public/org/apache/ws/commons/ws-commons-util/1.0.1/ws-commons-util-1.0.1.pom'.

  • Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 6 mins 25.964 secs



I would be very grateful if somebody could point out what I need to do it right to build rosjava_core. Cheers, Bernd


[1] http://docs.rosjava.googlecode.com/hg/rosjava_core/html/index.html

[2] http://www.ros.org/wiki/electric/Installation/Ubuntu

[3] http://docs.rosjava.googlecode.com/hg/rosjava_core/html/installing.html

[4] http://docs.rosjava.googlecode.com/hg/rosjava_core/html/building.html


Originally posted by Bernd Kampl on ROS Answers with karma: 76 on 2012-08-31

Post score: 0

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

The better solution is to use the "mavenCentral()" (similar to "mavenLocal()") method. This change will be applied everywhere soon.


Originally posted by damonkohler with karma: 3838 on 2012-09-12

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$
0
$\begingroup$

Rosanswers logo

Turns out I found a solution to this, although it might not be perfect. In the folder "rosjava_core" open up the file "build.gradle" and on line 39 replace

url 'http://robotbrains.hideho.org/nexus/content/groups/ros-public'

with

url 'https://maven-us.nuxeo.org/nexus/content/repositories/public'

and then it will compile.


Originally posted by Bernd Kampl with karma: 76 on 2012-09-02

This answer was NOT ACCEPTED on the original site

Post score: 2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.