0
$\begingroup$

Rosanswers logo

I just installed ubuntu 12.04 and ROS fuerte. When I run 'roslaunch pr2_gazebo pr2_empty_world.launch' the entire pr2 model is not showed up on screen.

I only installed ROS and PR2 simulator package. Is there anybody helps me?

The terminal shows following messages:

Segmentation fault (core dumped) Traceback (most recent call last): File "/opt/ros/fuerte/stacks/pr2_mechanism/pr2_controller_manager/scripts/spawner", line 161, in if name == 'main': main() File "/opt/ros/fuerte/stacks/pr2_mechanism/pr2_controller_manager/scripts/spawner", line 139, in main resp = load_controller(name) File "/opt/ros/fuerte/lib/python2.7/dist-packages/rospy/impl/tcpros_service.py", line 432, in call return self.call(*args, **kwds) File "/opt/ros/fuerte/lib/python2.7/dist-packages/rospy/impl/tcpros_service.py", line 522, in call raise ServiceException("transport error completing service call: %s"%(str(e))) rospy.service.ServiceException: transport error completing service call: unable to receive data from sender, check sender's logs for details

[WARN] [WallTime: 1346191217.658283] [0.089000] Spawner couldn't reach pr2_controller_manager to take down controllers.

[gazebo-2] process has died [pid 23235, exit code 139, cmd /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gazebo -u /opt/ros/fuerte/stacks/simulator_gazebo/gazebo_worlds/worlds/empty.world __name:=gazebo __log:=/home/dpark/.ros/log/bb7462a6-f15b-11e1-acc1-38607740c1c2/gazebo-2.log]. log file: /home/dpark/.ros/log/bb7462a6-f15b-11e1-acc1-38607740c1c2/gazebo-2*.log

[spawn_pr2_model-4] process has finished cleanly log file: /home/dpark/.ros/log/bb7462a6-f15b-11e1-acc1-38607740c1c2/spawn_pr2_model-4*.log

[default_controllers_spawner-24] process has died [pid 24562, exit code 1, cmd /opt/ros/fuerte/stacks/pr2_mechanism/pr2_controller_manager/scripts/spawner --wait-for=/calibrated base_controller base_odometry head_traj_controller laser_tilt_controller torso_controller r_gripper_controller l_gripper_controller r_arm_controller l_arm_controller __name:=default_controllers_spawner __log:=/home/dpark/.ros/log/bb7462a6-f15b-11e1-acc1-38607740c1c2/default_controllers_spawner-24.log].

log file: /home/dpark/.ros/log/bb7462a6-f15b-11e1-acc1-38607740c1c2/default_controllers_spawner-24*.log


Originally posted by dpark on ROS Answers with karma: 1 on 2012-08-28

Post score: 0


Original comments

Comment by hsu on 2012-08-28:
Can you do "unset OGRE_RESOURCE_PATH" and try again? If gazebo still crashes, can you do "roslaunch gazebo_worlds debug.launch" then type "bt" at the gdb prompt after crashing: "(gdb) bt" and post all outputs? thanks.

Comment by dpark on 2012-08-29:
I did "unset OGRE_RESOURCE_PATH". Still it crashes. I also did "roslaunch gazebo_worlds debug.launch". It was not crash. The crash is only happen when I launch pr2 things~ Any suggestions? Thanks

Comment by hsu on 2012-08-29:
Hi, I am trying to make debugging process easier, can you take a look at this page (http://ros.org/wiki/simulator_gazebo/Troubleshooting) and fill in some more details as mentioned by the second half of the wiki here? Thanks.

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

[This question is almost a year old, but I still wanted to add my answer].

I also noticed this happening with

roslaunch pr2_gazebo pr2_empty_world.launch

which spawns the PR2 itself, so I tried spawning it myself in an empty world after reducing the solver step size and voilà!

So, while I guess it's not recommended to alter the file I'm about to mention, my solution is nonetheless, the following:

rosed gazebo_worlds empty.world

and change

<dt>0.001</dt>

to something like

<dt>0.0001</dt>

And then, whenever you launch the simulator, you just wait until everything has loaded and just set back the step size to whichever you prefer.


Originally posted by RayR with karma: 16 on 2013-05-24

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$
0
$\begingroup$

Rosanswers logo

I encountered the same problem and i solved by killing the server and client first and launch again

killall gzclient

killall gzserver

Originally posted by ljk with karma: 155 on 2013-11-03

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by hillripper21 on 2020-07-20:
2020 and this is the only thing that fixed my issue. Thank you

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.