0
$\begingroup$

Rosanswers logo

Hello,

I just installed openni_camera and openni_launch stacks. When I launch the driver and rviz using the following commands:

roslaunch openni_launch openni.launch

rosrun rviz rviz

in rviz, I see a warning telling me that it didn't receive any images. I try to echo the messages sent by /camera/rgb/image_raw, but no messages are published on that topic.

I need to mention that I get some number of messages from /camera/depth/points topic. The interesting thing here is that only a number of messages are published by that topic. It stops after a random number of messages.

There are a few similar problems like mine. Following the proposed answers, I suspect that my drivers might be faulty. But reinstalling them didn't solve the problem.

Here is a screen shot: In this run, I only got 74 point cloud messages. It just stopped at that point. I also didn't get any image messages.

I deeply appreciate any help.

EDIT: --------------------------------------------------------------

I must also add that when I run the following command:

rosrun image_view disparity_view image:=/camera/depth/disparity and not rviz, I can see the camera working for only a few(5-10) seconds, and again it hangs.

-------------------------------------------------------------------------

EDIT 2: --------------------------------------------------------------

I get lots of errors and warnings but they are said to be harmless, for example

  • Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored

  • [ERROR] [1346137170.283120890]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/compressed/set_parameters]

  • [ WARN] [1346137171.480522722]: Using default parameters for RGB camera calibration.

In several questions on Ros Answers, I ran into the problems with the same errors and warning. They all say that ignoring these errors wouldn't do any harm.

I paste the full output here

-------------------------------------------------------------------------

EDIT 3: I cannot comment on the posts, that's why I will post this edit. As pgorczak says, I don't believe that my problem is performance related, I use a powerful computer. In addition to that, even if I don't start rviz or image_view and just echo, let's say, /camera/rgb/image_raw, I don't see any messages on that topic. I believe openni just freezes.

I will keep trying to see if I can get it to work. And, thanks a lot pgorczak, I am looking forward to your update.


Originally posted by yigit on ROS Answers with karma: 796 on 2012-08-27

Post score: 1


Original comments

Comment by pgorczak on 2012-08-27:
Did you check for any suspicious log messages? Try running roscore and rxconsole before the driver's launch file and see if anything shows up when it hangs.

Comment by yigit on 2012-08-27:
I updated the question. Please check edit2.

Comment by georgebrindeiro on 2012-12-21:
@yygyt were you able to ever solve your problem? I think I am having the same issue. Are you using Ubuntu 12.04 64-bit? Are you using the openni-dev unstable and ps-engine avin2 packages found here?

Comment by yigit on 2012-12-23:
Yeah, somehow... Please take a look at this reply http://answers.ros.org/question/46066/kinect-dynamic-reconfigure-does-not-work/#46450. In my case, both problems are related

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

The first exception is not harmful as you can see here.

When I am using roslaunch openni_launch openni.launch, I also get messages like:

[ERROR] [1346317018.377804268]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/compressedDepth/set_parameters]
[ERROR] [1346317018.384694527]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/compressed/set_parameters]
[ERROR] [1346317018.413763705]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/theora/set_parameters]
(...)
[ WARN] [1346317020.499849507]: Camera calibration file (...)/rgb_A00364A06244047A.yaml not found.
[ WARN] [1346317020.500131130]: Using default parameters for RGB camera calibration.
[ WARN] [1346317020.500289570]: Camera calibration file (...)/depth_A00364A06244047A.yaml not found.
[ WARN] [1346317020.500426152]: Using default parameters for IR camera calibration.

Still, everything works just fine (image_view and rviz) so those shouldn't be the issue.

I think running only image_view like in your first edit and still getting the freeze pretty much rules out a performance issue--at least concerning rviz. I think (I'm not sure though) the point cloud only gets computed when you subscribe to the points topic which would mean there is pretty much nothing going on computationally when you just display an image with image_view.

You could also try a different Kinect device or make sure your Kinect works e.g. on Windows with the OpenNI examples to make sure there is no problem with the device itself.

And my last question would be: What is your version of ROS and your operating system (version)? I'm using ubuntu 12.04 with fuerte and it worked with the OpenNI-packages I got with sudo apt-get install ros-fuerte-openni-camera.

You could try the driver from openni_camera_deprecated just to see if it gives you different output or some hints on what's going on.

Kinect launch file using openni_camera/OpenNINodelet (deprecated version of the driver):

<launch> 
    <node pkg="nodelet" type="nodelet" name="openni_manager" output="screen" respawn="true" args="manager"/>
    <node pkg="nodelet" type="nodelet" name="openni_launch" args="load openni_camera/OpenNINodelet openni_manager" respawn="true">
        <!--<param name="rgb_frame_id" value="camera_rgb_optical_frame" />-->
        <!--<param name="depth_frame_id" value="camera_depth_optical_frame" />-->
        <param name="depth_registration" value="true" />
        <param name="image_mode" value="VGA_30Hz" />
        <param name="depth_mode" value="VGA_30Hz" />
        <param name="debayering" value="EdgeAwareWeighted" />
        <param name="depth_time_offset" value="-0.055" /> <!-- Taken from TurtleBot's kinect.launch -->
        <param name="image_time_offset" value="0" />
    </node>
</launch>

Originally posted by pgorczak with karma: 446 on 2012-08-29

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.