0
$\begingroup$

Rosanswers logo

I was trying to run a simulation in a virtual environment on gazebo. Therefore I launch the virtual environment in gazebo_worlds such as office_world.launch. The following error message occurred:

Msg Waiting for master[ INFO] [1345626416.332008069]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...

Msg Connected to gazebo master @ http://localhost:11345
[ INFO] [1345626419.675247663, 0.107000000]: waitForService: Service [/gazebo/set_physics_properties] is now available.
[ INFO] [1345626419.713744662, 2.769000000]: Starting to spin physics dynamic reconfigure node...

and gazebo window didn't occur

and I tried to launch empty_world.launch, it succeeded. Other launch file such as simple_office2.launch, simple_world.launch, wg_world.launch... failed, too.

How can I solve this problem or is there any other launch file that provides a complete virtual environment for simulation?

BTW I run Fuerte on Ubuntu 12.04

---------------------------------edit-------------------------------------

When I tried to launch simple_office2.launch, I got the following error:

Segmentation fault (core dumped)
[gazebo-2] process has died [pid 6666, exit code 139, cmd /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gazebo /opt/ros/fuerte/stacks/simulator_gazebo/gazebo_worlds/worlds/simple_office2.world __name:=gazebo __log:=/home/albert/.ros/log/99159028-edc2-11e1-b88b-5404a6dc3a5e/gazebo-2.log].
log file: /home/albert/.ros/log/99159028-edc2-11e1-b88b-5404a6dc3a5e/gazebo-2*.log

I've added a new line in the launch file

<node name="gazebo_gui" pkg="gazebo" type="gui" respawn="false" output="screen"/>

Originally posted by Albert K on ROS Answers with karma: 301 on 2012-08-21

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

make sure the following line is in the launch file

<node name="gazebo_gui" pkg="gazebo" type="gui" respawn="false" output="screen"/>

Originally posted by seth_g with karma: 178 on 2012-08-23

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by Albert K on 2012-08-23:
Thanks for the help. I could launch office_world.launch successfully. Buit while I tried to apply to other failed launch file, there were still some launch files that had error. I've post the new problem.

Comment by seth_g on 2012-08-24:
simple_office2 crashes for me as well. after digging I found it has something to do with the body:map world tags. the other world files that include the body:map tags have them commented out. unless you really want to use that world file, I wouldn't worry about it. you could always report a bug?

Comment by Albert K on 2012-08-26:
Do you have any idea about the body:map tag? As you say, there isn't such tag in other world file. I wonder if it is the reason that when I open rviz, the global fixed frame can't find "/map" and reports status error. Just a wild guess.

Comment by seth_g on 2012-09-11:
It's my understanding that it is a tag used to describe a map model within Gazebo. I haven't tried to use it nor have I explored the API for it, sorry. as for your fixed frame, I can't really say why it reports with an error. you might try /base_link instead of /map?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.